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Problembeschreibung

Wenn Sie das Business Portal für Microsoft Dynamics GP, für Microsoft Business Solutions – Great Plains oder für Microsoft Dynamics SL verwenden, ist der Berichts-Viewer leer, wenn Sie auf einen Berichtsnamen klicken, der auf der Mittelseite angezeigt wird.

Ursache

Ursache 1

Der Berichtsordner, in dem Berichte gespeichert werden, die aus Microsoft Dynamics GP oder Microsoft Dynamics SL veröffentlicht wurden, wird nicht freigegeben.

Die folgenden Benutzer und Gruppen müssen Vollzugriff auf die Berichtsfreigabe haben:

  • Die Gruppe "Jeder"

  • Der Netzwerkdienstbenutzer

  • Der Identitätsbenutzer für das Microsoft.BusinessPortal.Reports.FileService COM+-Objekt

  • Der Vom Unternehmensportal verwendete Identitätsbenutzer für den Anwendungspool

Weitere Informationen finden Sie unter Auflösung 1 im Abschnitt "Auflösung".

Ursache 2

Der Identitätsbenutzer für das Microsoft.BusinessPortal.Reports.FileService COM+-Objekt hat keinen Vollzugriff auf die Microsoft.BusinessPortal.Reports.FileService.dll Datei. Weitere Informationen finden Sie unter Auflösung 2 im Abschnitt "Auflösung".

Ursache 3

Der Speicherort der Berichtsfreigabe ist in der ReportCatalog-Tabelle nicht ordnungsgemäß aufgeführt. Weitere Informationen finden Sie unter Auflösung 3 im Abschnitt "Auflösung".

Ursache 4

Die Größe der Datei "Microsoft.BusinessPortal.Reports.FileService.tlb" beträgt 0 KB. Weitere Informationen finden Sie unter Auflösung 4 im Abschnitt "Auflösung".

Fehlerbehebung

Lösung 1

Führen Sie die folgenden Schritte aus, um den Berichtsordner zu teilen und Zugriff auf die Berichtsfreigabe für bestimmte Benutzer und Gruppen hinzuzufügen:

  1. Klicken Windows im Explorer mit der rechten Maustaste auf den Ordner mit den Berichten, die aus Microsoft Dynamics GP oder Microsoft Dynamics SL veröffentlicht wurden. Klicken Sie dann auf Eigenschaften.

  2. Klicken Sie auf die Registerkarte Freigabe, klicken Sie auf Diesen Ordner freigeben, und klicken Sie dann auf Berechtigungen.

  3. Klicken Sie aufHinzufügen , geben Sie Jeder ein, klicken Sie auf Namen überprüfen,und klicken Sie dann auf OK.

  4. Klicken Sie auf den Eintrag Jeder.

  5. Klicken Sie im Bereich Berechtigungen für jeden auf das Kontrollkästchen Vollzugriff, um es zu aktivieren, und klicken Sie dann auf OK.

Hinweis Wiederholen Sie die Schritte 3 bis 5 für die anderen Benutzer und Gruppen, die im Abschnitt "Ursache" erwähnt werden. Der Netzwerkdienstbenutzer ist ein lokaler Benutzer. Informationen zu den Namen der anderen Benutzer und Gruppen, die Sie hinzufügen müssen, finden Sie im Abschnitt "Weitere Informationen".

Lösung 2

Führen Sie die folgenden Schritte aus, um den richtigen Zugriff für das COM+-Objekt hinzuzufügen:

  1. Klicken Windows im Explorer mit der rechten Maustaste auf die Microsoft.BusinessPortal.Reports.FileService.dll Datei, und klicken Sie dann auf Eigenschaften.

    Hinweis Diese Datei befindet sich standardmäßig unter dem folgenden Pfad:

    C:\Inetpub\wwwroot\bin

  2. Klicken Sie auf die Registerkarte Sicherheit, klicken Sie auf Hinzufügen, klicken Sie auf Speicherorte, wählen Sie den Namen des Business Portal-Servers aus, und klicken Sie dann auf OK.

  3. Geben Sie den Namen des Benutzers ein, klicken Sie auf Namen überprüfen, und klicken Sie dann auf OK.

    Hinweis Informationen zum Ermitteln des Namens des Identitätsbenutzers für das Microsoft.BusinessPortal.Reports.FileService COM+-Objekt finden Sie im Abschnitt "Weitere Informationen".

  4. Klicken Sie auf den Benutzernamen.

  5. Klicken Sie im Bereich Berechtigungen auf das Kontrollkästchen Vollzugriff, um es zu aktivieren, und klicken Sie dann auf OK.

Lösung 3

Um den Speicherort der Berichtsfreigabe in der ReportCatalog-Tabelle zu korrigieren, führen Sie das folgende Skript für die Unternehmensdatenbank aus.

SELECT  * FROM ReportCatalog

Die Report_URL muss auf die Berichtsfreigabe verweisen. Wenn sich der Report.txt-Bericht beispielsweise im Ordner "C:\Reports" auf dem BusinessPortalServer-Berichtsserver befindet, muss der Wert in der Spalte Report_URL der folgende Wert sein:

BusinessPortalServer/Reports/Report.txt

Auflösung 4

  1. Suchen Windows im Explorer die Datei Microsoft.BusinessPortal.Reports.FileService.tlb.

    Hinweis Diese Datei befindet sich standardmäßig im folgenden Ordner:

    c:\inetpub\wwwroot\bin

  2. Wenn die Dateigröße 0 KB beträgt, benennen Sie die Datei um, indem Sie den folgenden Dateinamen verwenden:

    Microsoft.BusinessPortal.Reports.FileService.tlbold

  3. Klicken Sie auf den folgenden Link, um eine neue Microsoft.BusinessPortal.Reports.FileService.tlb-Datei herunterzuladen:

    https://mbs.microsoft.com/fileexchange/?fileID=aab68342-5ba5-4084-adf0-44271a6f3141

  4. Fügen Sie die Datei in denselben Ordner ein, in dem sich auch das ursprüngliche Microsoft.BusinessPortal.Reports.FileService.tlb befand.

Weitere Informationen

Führen Sie die folgenden Schritte aus, um den Identitätsbenutzer für das Microsoft.BusinessPortal.Reports.FileService COM+-Objekt zu ermitteln:

  1. Klicken Sie auf Start, klicken Sie auf Verwaltungstools, und klicken Sie dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste, erweitern Sie Computer, erweitern Sie Mein Computer, und erweitern Sie dann COM+ Anwendungen.

  3. Klicken Sie mit der rechten Maustaste auf Microsoft.BusinessPortal.Reports.FileService, klicken Sie auf Eigenschaften, und klicken Sie dann auf die Registerkarte Identität.

Führen Sie die folgenden Schritte aus, um den Identitätsbenutzer für den von Business Portal verwendeten Anwendungspool zu ermitteln:

  1. Klicken Sie auf Start, klicken Sie auf Verwaltungstools, und klicken Sie Internetinformationsdienste (IIS)-Manager.

  2. Erweitern Sie den Computernamen und dann Anwendungspools.

  3. Suchen Sie den Anwendungspool, den Sie für das Unternehmensportal verwenden.

  4. Klicken Sie mit der rechten Maustaste auf den Anwendungspool, klicken Sie auf Eigenschaften, und klicken Sie dann auf Identität.

Informationsquellen

Wenn Sie weitere Informationen zu den Schritten zur Problembehandlung erhalten möchten, die erforderlich sind, wenn FRx-Berichte nicht im Geschäftsportal angezeigt werden, klicken Sie auf die folgende Artikelnummer, um den Artikel in der Microsoft Knowledge Base anzeigen:

861754 Sie können FRx-Berichte im Geschäftsportal nicht in Salomonen und great Plains

861754 anzeigen.

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