Hinweis: Die Internet Explorer 11-Desktopanwendung wird eingestellt und wird am 15. Juni 2022 nicht mehr unterstützt (eine Liste der Bereiche finden Sie unter Häufiggestellte Fragen). Die gleichen IE11-Apps und -Websites, die Sie heute verwenden, können Microsoft Edge Internet Explorer-Modus geöffnet werden. Weitere Informationen finden Sie hier.

Problembeschreibung

Auf einem Computer, auf dem Windows 7 oder Windows Server 2008 R2 ausgeführt wird, verwenden Sie Windows Internet Explorer 8, um eine Webseite zu durchsuchen. Sie maximieren das Fenster, das die Webseite enthält. Diese Webseite enthält ein Popupfenster. In diesem Szenario wird ein Teil des Popupfensters nicht auf dem Bildschirm angezeigt. Sie erwarten jedoch, dass das Popupfenster vollständig auf dem Bildschirm angezeigt wird.

Ursache

Dieses Problem tritt aufgrund einer Entwurfsänderung in ihrer Internet Explorer 8. Um die Verwendung auf mehreren Monitoren zu unterstützen, Internet Explorer 8 Popupfenster nicht auf den Anzeigebereich eines einzelnen Monitors beschränkt.

Fehlerbehebung

Sicherheitsupdateinformationen

Um dieses Problem zu beheben, installieren Sie das neueste kumulative Sicherheitsupdate für Windows Internet Explorer. Rufen Sie hierzu die folgende Microsoft-Website auf:

http://update.microsoft.comWeitere technische Informationen zum neuesten kumulativen Sicherheitsupdate für Windows Internet Explorer finden Sie auf der folgenden Microsoft-Website:

http://www.microsoft.com/technet/security/current.aspxHinweis Dieses Update wurde erstmals im Sicherheitsupdate 974455 (MS09-054) enthalten. Um weitere Informationen zu erhalten, klicken Sie auf die folgende Artikelnummer, um den Artikel in der Microsoft Knowledge Base zu lesen:

974455 MS09-054: Kumulatives Sicherheitsupdate für Internet Explorer

Informationen zum Hotfix

Ein unterstützter Hotfix ist jetzt von Microsoft verfügbar. Es soll jedoch nur das in diesem Artikel beschriebene Problem beheben. Wenden Sie sie nur auf Systeme an, die dieses spezifische Problem haben. Dieser Hotfix kann zusätzliche Tests erhalten. Wenn Sie von diesem Problem nicht besonders betroffen sind, sollten Sie daher auf das nächste Softwareupdate warten, das diesen Hotfix enthält.

Um dieses Problem sofort zu beheben, wenden Sie sich an den Microsoft Customer Support Services, um den Hotfix zu erhalten. Eine vollständige Liste der Microsoft Customer Support Services-Telefonnummern und Informationen zu Supportkosten finden Sie auf der folgenden Microsoft-Website:

http://support.microsoft.com/contactus/?ws=supportHinweis In Sonderfällen können Gebühren, die normalerweise für Supportanrufe anfallen, storniert werden, wenn eine Microsoft Support Professional feststellt, dass Ihr Problem durch ein bestimmtes Update behoben wird. Die üblichen Supportkosten gelten für weitere Supportfragen und -probleme, die für das spezifische Update nicht berechtigt sind.

Voraussetzungen

Um diesen Hotfix zu installieren, muss Internet Explorer 8 auf einem Computer mit einem der folgenden Betriebssysteme installiert sein:

  • Windows 7

  • Windows Server 2008 R2

Neustartanforderung

Nachdem Sie diesen Hotfix angewendet haben, müssen Sie den Computer neu starten.

Ersetzte Hotfixes

Dieser Hotfix ersetzt nicht einen zuvor veröffentlichten Hotfix.

Registrierungsinformationen


Wichtig Dieser Abschnitt, diese Methode oder Aufgabe enthält Schritte, die Sie informieren, wie Sie die Registrierung ändern. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher ist es wichtig, bei der Ausführung der folgenden Schritte sorgfältig vorzugehen. Als Schutzmaßnahme sollten Sie vor der Bearbeitung der Registrierung eine Sicherungskopie erstellen. So ist gewährleistet, dass Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Erstellen und Wiederherstellen einer Sicherungskopie der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:

322756 Sichern und Wiederherstellen der Registrierung in WindowsNachdem Sie diesen Hotfix installiert haben, müssen Sie einen Registrierungswert hinzufügen, um den Hotfix zu aktivieren. Gehen Sie zu diesem Zweck folgendermaßen vor:

  1. Klicken Sie auf Schaltfläche "Start" , geben Sie regedit in das Feld Suche starten ein, und drücken Sie dann die EINGABETASTE.

    Berechtigung "Benutzerkontensteuerung" Sie zur Eingabe eines Administratorkennworts oder zur Bestätigung aufgefordert werden, geben Sie das Kennwort ein, oder bestätigen Sie die Eingabe.

  2. Suchen Sie den folgenden Registrierungsunterschlüssel, und klicken Sie darauf:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl

  3. Zeigen Sie im Menü Bearbeiten auf Neu, und klicken Sie anschließend auf Schlüssel.

  4. Geben Sie den folgenden Schlüsselnamen ein, und drücken Sie dann die EINGABETASTE:

    FEATURE_FORCE_POPUPS_ONTO_MONITOR_KB974537

  5. Zeigen Sie im Menü Bearbeiten auf Neu, und klicken Sie anschließend auf DWORD-Wert.

  6. Geben Sie iexplore.exe ein, und drücken Sie dann die EINGABETASTE.

  7. Klicken Sie mit der iexplore.exe, und klicken Sie dann auf Ändern.

  8. Geben Sie im Feld Wertdaten den Wert 1 ein, und klicken Sie dann auf OK.

  9. Beenden Sie den Registrierungs-Editor.

Dateiinformationen

Die englische Version dieses Hotfixes weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf. Datums- und Uhrzeitangaben für diese Dateien sind in der "Universal Time Coordinated" (UTC) angegeben. Wenn Sie die Dateiinformationen anzeigen, werden diese Angaben in die Ortszeit umgewandelt. Den Unterschied zwischen UTC- und Ortszeit können Sie in der Systemsteuerung unter Datum und Uhrzeit mithilfe der Angaben auf der Registerkarte Zeitzone ermitteln.

Für alle unterstützten x86-basierten Internet Explorer 8 für Windows 7

File name

Dateiversion

Dateigröße

Datum

Time

Platform

Microsoft-windows-ie-htmlrendering.ptxml

Nicht anwendbar

1,141

13.07.2009

20:45

Nicht anwendbar

Mshtml.dll

8.0.7600.20513

5,958,656

24. August 2009

05:47

x86

Mshtml.tlb

8.0.7600.16385

1,638,912

13.07.2009

23:42

Nicht anwendbar

Für alle unterstützten x64-basierten Internet Explorer 8 für Windows 7 und Windows Server 2008 R2

File name

Dateiversion

Dateigröße

Datum

Time

Platform

Microsoft-windows-ie-htmlrendering.ptxml

Nicht anwendbar

1,141

13.07.2009

20:36

Nicht anwendbar

Mshtml.dll

8.0.7600.20513

9,274,880

24. August 2009

06:41

x64

Mshtml.tlb

8.0.7600.16385

1,638,912

13.07.2009

23:58

Nicht anwendbar

Mshtml.dll

8.0.7600.20513

5,958,656

24. August 2009

05:47

x86

Mshtml.tlb

8.0.7600.16385

1,638,912

13.07.2009

23:42

Nicht anwendbar

Wow64_microsoft-windows-ie-htmlrendering.ptxml

Nicht anwendbar

1,141

13.07.2009

20:45

Nicht anwendbar

Für alle unterstützten IA64-basierten Internet Explorer 8 für Windows Server 2008 R2

File name

Dateiversion

Dateigröße

Datum

Time

Platform

Microsoft-windows-ie-htmlrendering.ptxml

Nicht anwendbar

1,141

13.07.2009

20:36

Nicht anwendbar

Mshtml.dll

8.0.7600.20513

9,274,880

24. August 2009

06:41

x64

Mshtml.tlb

8.0.7600.16385

1,638,912

13.07.2009

23:58

Nicht anwendbar

Mshtml.dll

8.0.7600.20513

5,958,656

24. August 2009

05:47

x86

Mshtml.tlb

8.0.7600.16385

1,638,912

13.07.2009

23:42

Nicht anwendbar

Wow64_microsoft-windows-ie-htmlrendering.ptxml

Nicht anwendbar

1,141

13.07.2009

20:45

Nicht anwendbar

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

Weitere Informationen

Weitere Informationen zur Methode "Anzeigen" finden Sie auf der folgenden Microsoft-Website:

http://msdn.microsoft.com/hi-in/library/ms536755(de-DE,VS.85).aspxWeitere Informationen zu Popupelementen finden Sie auf der folgenden Microsoft-Website:

http://msdn.microsoft.com/en-au/library/ms533025(VS.85).aspx

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Microsoft Insider beitreten

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Übersetzungsqualität?
Was hat Ihre Erfahrung beeinflusst?

Vielen Dank für Ihr Feedback!

×