Problembeschreibung
Wenn Sie Microsoft Dynamics AX 4.0 Service Pack 1 (SP1) auf einem Clientcomputer starten, wird die folgende Fehlermeldung angezeigt:
Fehler in der Datei: \\Microsoft Dynamics AX installation path\appl\standard\axsys.aod while reading in record = 0 Windows
error: = Error
code: 64 = The specified network name is not available.
Wiederholen?
Darüber hinaus wird auf dem Clientcomputer das folgende Ereignis protokolliert:Notes
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In dieser Fehlermeldung ist das Wort "aufgetreten" ein Rechtschreibfehler für das Wort "aufgetreten".
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Der file_name in der Fehlerbeschreibung stellt eine Datei dar, die sich in dem freigegebenen Ordner befindet, der die Programminstallationsdateien enthält.
Ursache
Dieses Problem kann auftreten, wenn eine der folgenden Bedingungen erfüllt ist:
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Der AOS-Dienst (Application Object Server) wird beendet.
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Es ist ein Stromausfall, ein Schalterfehler oder ein Hardwarefehler aufgetreten, der dazu führte, dass die Verbindung plötzlich beendet wurde.
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Einige Dateien wurden durch Virenscan- oder -sicherungssoftware gesperrt.
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Die Netzwerkverbindung mit dem freigegebenen Ordner, der die Programminstallationsdateien enthält, ist verloren gegangen.
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Codeänderungen wurden bereitgestellt, während andere Benutzer Microsoft Dynamics AX verwendeten.
Hinweis Weitere Informationen zum Bereitstellen von Codeänderungen finden Sie im Microsoft Dynamics AX Developers Guide. Zum Anzeigen dieses Handbuchs klicken Sie auf Hilfeund dann auf Microsoft Dynamics AX Developer's Guide.
Fehlerbehebung
Gehen Sie folgendermaßen vor, um das Problem zu beheben:
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Beenden Sie den AOS-Dienst. Klicken Sie dazu auf Start, klicken Sie auf Ausführen,geben Sie services.msc ein, und klicken Sie dann auf OK. Suchen Sie den AOS-Dienst. Wenn der Dienst ausgeführt wird, klicken Sie mit der rechten Maustaste auf den Dienst, und klicken Sie dann auf Beenden.
Hinweis Der AOS-Dienstname verwendet das folgende Format:Dynamics Server$ instance-number AOS-instance-name
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Starten Sie die Supportadministrator-Konsole, Microsoft SQL Query Analyzer oder SQL Server Management Studio. Verwenden Sie dazu je nach verwendeten Programm eine der folgenden Methoden.
Methode 1: Wenn Sie SQL Server Desktop Engine (auch bekannt als MSDE 2000) für SQL Server Desktop Engine verwenden, starten Sie die Support-Administratorkonsole. Klicken Sie dazu auf Start , zeigenSie auf Alle Programme,zeigen Sie auf Microsoft Administrator Console, und klicken Sie dann auf Support-Administratorkonsole.
Methode 2: Für SQL Server 2000 Starten Sie SQL Server 2000 SQL Abfrageanalyse. Klicken Sie dazu auf Start, zeigen Sie auf Alle Programme,zeigen Sie aufMicrosoft SQL Server , und klicken Sie dann auf Abfrageanalyse.
Methode 3: Bei SQL Server 2005 beginnen Sie mit SQL Server 2005 SQL Server Management Studio. Klicken Sie dazu auf Start, zeigen Sie auf Alle Programme, zeigen Sie auf Microsoft SQL Server 2005,und klicken Sie dann auf SQL Server Management Studio.
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Schließen Sie alle offenen Verbindungen mit dem Microsoft Dynamics AX-Datenbankserver.
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Starten Sie den AOS-Dienst neu.
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Starten Sie den Microsoft Dynamics AX-Client neu.
Weitere Informationen
Verwenden Sie eine oder mehrere der folgenden Methoden, um dieses Problem zu verhindern:
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Verwenden Sie in den AOS-Konfigurationseinstellungen eine IP-Adresse anstelle eines DNS-Namens (Domain Name System), eines zugeordneten Laufwerks oder eines ausgeblendeten freigegebenen Ordners, der die Programminstallationsdateien enthält.
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Während die Server verbunden sind, auf denen der AOS-Dienst ausgeführt wird, deaktivieren Sie die Virenprüfung des freigegebenen Ordners, der die freigegebenen Programmdateien enthält, in Echtzeit.
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Eine falsche Konfiguration der Teamnetzwerkadapter kann Verbindungsprobleme verursachen. Stellen Sie sicher, dass die Option "Energie speichern" auf dem Netzwerkadapter nicht aktiviert ist. Der AOS-Dienst und der Client verwenden den ersten verfügbaren Netzwerkadapter. Stellen Sie sicher, dass sich die LOKALEN LAN-Adapter (Local Area Network) vor allen Drahtlosnetzwerkadaptern zuerst in der Bindungsreihenfolge befinden.
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Überwachen Sie die gesperrten Dateien und die verfügbaren Dateien mithilfe der Computerverwaltungskonsole auf dem Programmdateiserver. Gehen Sie zu diesem Zweck folgendermaßen vor:
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Klicken Sie auf Start, klicken Sie auf Ausführen,geben Sie compmgmt.msc ein, und klicken Sie dann auf OK.
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Klicken Sie in der Computerverwaltungs-Konsolenstruktur auf Freigegebene Ordner.
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