Symptom
Der Benutzer führt einen Desktopfluss im unbeaufsichtigten Modus aus, und die Ausführung schlägt fehl, da die richtigen UI-Elemente nicht zu finden sind. Fehlerscreenshots zeigen, dass sich die Bildschirmauflösung zur Laufzeit von der beim Erstellen des Desktopflusses verwendeten Bildschirmauflösung unterscheiden.
Ursache
Einige Windows oder VMs können standardmäßig eine geringere Bildschirmauflösung haben, wenn unbeaufsichtigte Desktopflüsse ausgeführt werden. Wenn bei den automatisierten Anwendungen die Bildschirmauflösung beachtet wird oder Sie bildbasierte Automatisierung verwenden, kann dies zu einem Fehl fehl am Desktopfluss führen.
Lösung
Legen Sie die Standardauflösung in der UIFlowService.exe.config-Datei:
-
Navigieren Sie zu "C:\Programme (x86)\Power Automate Desktop"
-
Öffnen UIFlowService.exe.config-Editors in einem Texteditor
-
Legen Sie Microsoft. Flow. RPA. UIFlowService.ScreenDefaultResolutionEnabled to true
-
Passen Sie die Standardmäßige Bildschirmauflösung an, indem Sie die Eigenschaften Breite und Höhe festlegen:
<!-- Screen resolution settings -->
<add key="Microsoft.Flow.RPA.UIFlowService.ScreenDefaultResolutionEnabled" value="true" />
<add key="Microsoft.Flow.RPA.UIFlowService.ScreenDefaultResolutionWidth" value="1920" />
<add key="Microsoft.Flow.RPA.UIFlowService.ScreenDefaultResolutionHeight" value="1080" />
<add key="Microsoft.Flow.RPA.UIFlowService.ScreenDefaultResolutionScale" value="100" />
-
Wechseln Sie zum Startmenü > Services, suchen Sie den "Power Automate-Dienst" (in älteren Versionen wird dieser als "UIFlowService" bezeichnet, und der Prozessname ist UIFlowService.exe, wenn Sie Task-Manager verwenden). Starten Sie diesen Dienst neu, indem Sie mit der rechten Maustaste klicken und "Neu starten" drücken. Wenn Sie es vorziehen, können Sie Ihren Computer auch einfach neu starten.