Bei Microsoft anmelden
Melden Sie sich an, oder erstellen Sie ein Konto.
Hallo,
Wählen Sie ein anderes Konto aus.
Sie haben mehrere Konten.
Wählen Sie das Konto aus, mit dem Sie sich anmelden möchten.

Problembeschreibung

Beim Ausführen einer Websites, die die Pipeline Werbung auf einem Server mit Microsoft Commerce Server 2007 oder Microsoft Commerce Server 2009 führt, erhalten Sie eine Fehlermeldung, die der folgenden ähnelt:

' HttpContext.Current ' ist null Commerce.CSFLoadHistory.1

Darüber hinaus wird ein Ereignis etwa folgender Art im Anwendungsprotokoll protokolliert:

Ursache

Dieses Problem tritt auf, weil die Komponenten LoadHistory, SaveHistory und IISAppendToLog ASP.NET Kontext überprüfen. Allerdings ist nicht für diese Komponenten ASP.NET Kontext und in einigen Szenarien kann diese Überprüfung Probleme verursachen. Werbung-Pipeline umfasst drei Komponenten. Daher tritt dieses Problem.

Lösung

Um dieses Problem zu beheben, die Server mit Commerce Server 2007 zu Commerce Server 2009 wenden Sie diesen Hotfix an.

Weitere Informationen zu diesem Update

Informationen zum Hotfix

Ein unterstützter Hotfix ist von Microsoft erhältlich. Allerdings soll diesen Hotfix nur das Problem zu beheben, die in diesem Artikel beschrieben. Wenden Sie dieses Hotfix nur auf Systeme an, bei denen das in diesem Artikel beschriebene Problem auftritt. Dieser Hotfix sollte weiteren Tests unterzogen werden. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir sie, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält. Wenn der Hotfix zum Download zur Verfügung steht, gibt es einen Abschnitt "Hotfixdownload available" ("Hotfixdownload verfügbar"), am oberen Rand dieses Knowledge Base-Artikel. Wenn dieser Abschnitt nicht angezeigt wird, wenden Sie sich an den Microsoft Customer Service and Support, um den Hotfix zu erhalten. Hinweis Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten für zusätzliche Supportfragen und Probleme, die nicht diesem speziellen Hotfix zugeordnet werden können. Für eine vollständige Liste der Telefonnummern von Microsoft Customer Service and Support oder für Erstellung eine separate Serviceanfrage, fahren Sie auf der folgenden Microsoft-Website fort:

http://support.microsoft.com/contactus/?ws=supportHinweis Das Formular "Hotfix download available" ("Hotfixdownload verfügbar") zeigt die Sprachen an, für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist dieser Hotfix für Ihre Sprache nicht verfügbar.

Voraussetzungen

Sie müssen die folgenden Hotfixes installiert:

  • Microsoft Commerce Server 2007 Servicepack 2 (SP2)

  • Microsoft Commerce Server 2009

Informationen zum Neustart

Sie müssen keinen Neustart des Computers nach der Installation dieses Hotfixes durchführen. Allerdings müssen Sie Internetinformationsdienste (IIS) starten, nachdem Sie diesen Hotfix anwenden. Neustart von IIS, Befehlszeile geben Sie folgenden Befehl ein und drücken Sie anschließend:

Iisreset /restartHinweis Dieser Befehl beendet und neu gestartet alle IIS-Dienste ausgeführt werden.

Dateiinformationen

Die englische Version dieses Hotfixes weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf. Datums- und Uhrzeitangaben für diese Dateien sind in der "Universal Time Coordinated" (UTC) angegeben. Wenn Sie die Dateiinformationen anzeigen, werden diese Angaben in die Ortszeit umgewandelt. Den Unterschied zwischen UTC- und Ortszeit können Sie in der Systemsteuerung unter Datum und Uhrzeit mithilfe der Angaben auf der Registerkarte Zeitzone ermitteln.

Für alle unterstützten Versionen von Commerce Server 2007-basierten x86

Dateiname

Dateiversion

Dateigröße

Datum

Uhrzeit

Plattform

Aspintrinsics.dll

6.0.4109.47

16,656

24-Aug-2010

13:46

x86

Csfcomp.dll

6.0.4109.47

281,352

24-Aug-2010

13:48

x86

Für alle unterstützten Versionen von Commerce Server 2007-basierten x64

Dateiname

Dateiversion

Dateigröße

Datum

Uhrzeit

Plattform

Aspintrinsics.dll

6.0.4109.47

16,656

24-Aug-2010

13:46

x86

Csfcomp.dll

6.0.4109.47

281,352

24-Aug-2010

13:48

x86

Csfcomp.dll

6.0.4109.47

485,128

24-Aug-2010

13:48

x64

Für alle unterstützten X86-basierten Versionen von Commerce Server 2009

Dateiname

Dateiversion

Dateigröße

Datum

Uhrzeit

Plattform

Aspintrinsics.dll

6.0.4171.28

16,656

31-Aug-2010

13:14

x86

Cs2009hotfixhelper.exe

6.0.4171.28

13,080

31-Aug-2010

13:14

x86

Csfcomp.dll

6.0.4171.28

281,352

31-Aug-2010

13:16

x86

Für alle unterstützten X64-basierten Versionen von Commerce Server 2009

Dateiname

Dateiversion

Dateigröße

Datum

Uhrzeit

Plattform

Aspintrinsics.dll

6.0.4171.28

16,656

31-Aug-2010

13:14

x86

Cs2009hotfixhelper.exe

6.0.4171.28

13,080

31-Aug-2010

13:14

x86

Csfcomp.dll

6.0.4171.28

281,352

31-Aug-2010

13:16

x86

Csfcomp.dll

6.0.4171.28

485,128

31-Aug-2010

13:16

x64

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

Benötigen Sie weitere Hilfe?

Möchten Sie weitere Optionen?

Erkunden Sie die Abonnementvorteile, durchsuchen Sie Trainingskurse, erfahren Sie, wie Sie Ihr Gerät schützen und vieles mehr.

In den Communities können Sie Fragen stellen und beantworten, Feedback geben und von Experten mit umfassendem Wissen hören.

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Sprachqualität?
Was hat Ihre Erfahrung beeinflusst?
Wenn Sie auf "Absenden" klicken, wird Ihr Feedback zur Verbesserung von Produkten und Diensten von Microsoft verwendet. Ihr IT-Administrator kann diese Daten sammeln. Datenschutzbestimmungen.

Vielen Dank für Ihr Feedback!

×