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PROBLEM

Office 365- oder eigenständige Exchange Online Protection-Abonnenten, die zuvor einen eigenständigen Forefront Online Protection for Exchange (FOPE) abonniert haben, erhalten einen Fehlerbericht zur Verzeichnissynchronisierung, der den folgenden Konflikt identifiziert:

Ein Objekt mit derselben Proxyadresse ist bereits in Windows Azure Active Directory vorhanden, hat jedoch einen inkompatiblen Objekttyp (Objektklassen: Kontakt, Gruppe oder Benutzer). Beheben Sie dieses Problem in den lokalen Verzeichnisdiensten oder in Windows Azure Active Directory, und versuchen Sie es erneut.

Im Folgenden finden Sie ein alternate text Beispiel für den Fehlerbericht: Zusätzliche Spalten im Fehlerbericht enthalten die Identität und die lokale Objekt-ID für in Konflikt stehende Objekte.

URSACHE

Dieses Problem tritt auf, weil migrierte Verteilergruppen und Kontakte von eigenständigem FOPE zu Exchange Online Protection mit einer falschen Objektklasse für die Soft-Matching-Verzeichnissynchronisierung erstellt wurden.

LÖSUNG

Entfernen Sie die in Konflikt stehenden Benutzer aus Office 365, um dieses Problem zu beheben. Erstellen Sie dazu eine Liste der zu entfernenden Benutzer, und führen Sie dann einen Windows PowerShell-Befehl aus, um den Entfernungsprozess durchzuführen. Führen Sie hierzu die folgenden Schritte aus:

  1. Stellen Sie eine Verbindung mit Azure AD her, indem Sie das Microsoft Azure Active Directory-Modul für Windows PowerShell verwenden. Weitere Informationen hierzu finden Sie unter Verwalten von Azure AD mithilfe von Windows PowerShell.

  2. Melden Sie sich beim Exchange-Administratorcenter an, und legen Sie dann alle betroffenen Domänen auf Internes Relay fest, um sicherzustellen, dass der Nachrichtenfluss während des Objekttypkorrekturintervalls nicht beeinträchtigt wird. Weitere Informationen hierzu finden Sie unter Verwaltete akzeptierte Domänen in Exchange Online.

  3. Führen Sie den folgenden Befehl aus, um eine Liste aller Office 365- oder Exchange Online Protection-Benutzer in eine Datei "Users.csv" zu exportieren:

    Get-MsolUser -All | Where {$_.ImmutableID -eq $null -and $_.IsLicensed -eq $false –and $_.ProxyAddresses –ne “”} | Export-CSV C:\users.csvU 
  4. Verwenden Sie Microsoft Excel oder einen Texteditor, um die Datei Users.csv zu öffnen. Wichtig Wenn Sie diese Schritte ausführen, ändern oder löschen Sie die beiden obersten Zeilen der Kalkulationstabelle nicht, da sie wichtige Kopfzeileninformationen enthalten.

    1. Löschen Sie in der Kalkulationstabelle die Zeilen, die den Benutzern zugeordnet sind, die Sie in Office 365 behalten möchten.

    2. Speichern Sie die Datei als Users-modified.csv.

  5. Führen Sie den folgenden Befehl aus, um die Benutzer aus Office 365 zu entfernen:

    Import-CSV C:\users-modified.csv | Remove-MsolUser –Force 
  6. Erzwingen der Verzeichnissynchronisierung. Weitere Informationen hierzu finden Sie unter Synchronisieren Ihrer Verzeichnisse.

  7. Führen Sie den folgenden Befehl aus, um Benutzer aus dem Papierkorb zu entfernen:

    Import-CSV C:\users-modified.csv | Get-MsolUser -ReturnDeletedUsers | Remove-MsolUser -RemoveFromRecycleBin  –Force 

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