Bei Microsoft anmelden
Melden Sie sich an, oder erstellen Sie ein Konto.
Hallo,
Wählen Sie ein anderes Konto aus.
Sie haben mehrere Konten.
Wählen Sie das Konto aus, mit dem Sie sich anmelden möchten.

Problembeschreibung

Stellen Sie sich folgendes Szenario vor:

  • NetBIOS-Namen der Active Directory-Domäne enthält eine kaufmännische und-Zeichen in einer Umgebung mit Microsoft Exchange Server 2010 (&).

  • Sie versuchen, Exchange Server 2010 Service Pack 1 (SP1) auf einem Server in der Umgebung installieren.

In diesem Szenario schlägt die Installation fehl. Außerdem wird folgende Fehlermeldung angezeigt:

Bearbeiten von EntityName ist ein Fehler aufgetreten. Line7, 12 positionieren.

Ursache

Dieses Problem tritt auf, da das kaufmännische und-Zeichen in XML ein reserviertes Zeichen ist. Daher wird das Zeichen die Analyse für aktuellen Benutzer Anmeldung fehlschlägt.

Lösung

Gehen Sie folgendermaßen vor, um dieses Problem zu beheben.Hinweis Dieses Problem wird im Updaterollup 4 für Exchange Server 2010 Service Pack 1 behoben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:

2579150 Hinweise zum Updaterollup 4 für Exchange Server 2010 Servicepack 1

  1. Kopieren Sie die Installationsdateien von der CD auf eine Festplatte, und öffnen Sie die Datei ManageScheduledTask.ps1 im Ordner "Scripts".

  2. Suchen Sie die folgenden Zeilen:

    function Get-CurrentUserName { [System.Security.Principal.WindowsIdentity]$id = [System.Security.Principal.WindowsIdentity]::GetCurrent() $id.Name }
  3. Ändern Sie die Zeilen wie folgt:

    function Get-CurrentUserName{ [System.Security.Principal.WindowsIdentity]$id = [System.Security.Principal.WindowsIdentity]::GetCurrent() [System.String]$fixedName = $id.Name.Replace('&','`&') return $fixedName }
  4. Speichern Sie die Datei, und versuchen Sie, Exchange Server 2010 SP1 von der Festplatte zu installieren.

  5. Installieren Sie das folgende Update:

    2579150 Hinweise zum Updaterollup 4 für Exchange Server 2010 Servicepack 1

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

Benötigen Sie weitere Hilfe?

Möchten Sie weitere Optionen?

Erkunden Sie die Abonnementvorteile, durchsuchen Sie Trainingskurse, erfahren Sie, wie Sie Ihr Gerät schützen und vieles mehr.

In den Communities können Sie Fragen stellen und beantworten, Feedback geben und von Experten mit umfassendem Wissen hören.

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Sprachqualität?
Was hat Ihre Erfahrung beeinflusst?
Wenn Sie auf "Absenden" klicken, wird Ihr Feedback zur Verbesserung von Produkten und Diensten von Microsoft verwendet. Ihr IT-Administrator kann diese Daten sammeln. Datenschutzbestimmungen.

Vielen Dank für Ihr Feedback!

×