Μήνυμα σφάλματος όταν προσπαθείτε να εκτυπώσετε μια αναφορά στο Microsoft Dynamics CRM 4.0: "Δεν είναι δυνατή η φόρτωση του ελέγχου εκτύπωσης του προγράμματος-πελάτη"

Ισχύει για
Dynamics CRM 4.0

Συμπτώματα

Όταν προσπαθείτε να εκτυπώσετε μια αναφορά στο Microsoft Dynamics CRM 4.0, λαμβάνετε το ακόλουθο μήνυμα λάθους:

Σημείωση

Δεν είναι δυνατή η φόρτωση του ελέγχου εκτύπωσης προγράμματος-πελάτη.

Αυτό το ζήτημα προκύπτει, εάν εγκαταστήσετε την ενημερωμένη έκδοση για SQL Server 2005 Service Pack 2 έκδοση γενικής διανομής (GDR).

Για περισσότερες πληροφορίες σχετικά με την ενημερωμένη έκδοση για το SQL Server 2005 Service Pack 2 GDR, κάντε κλικ στον αριθμό του άρθρου παρακάτω, για να προβάλετε το άρθρο της Γνωσιακής Βάσης της Microsoft:

954606 MS08-052: Περιγραφή της ενημερωμένης έκδοσης ασφαλείας του GDI+ για SQL Server 2005 Service Pack 2 GDR: 9 Σεπτεμβρίου 2008

Αιτία

Αυτό το ζήτημα παρουσιάζεται επειδή η ενημερωμένη έκδοση για το SQL Server 2005 Service Pack 2 GDR ενημερώνει τον αριθμό έκδοσης της κλάσης RSClientPrint. Επομένως, το στοιχείο ελέγχου reportviewer πρέπει επίσης να ενημερωθεί.

Επίλυση

Για να επιλύσετε αυτό το ζήτημα, χρησιμοποιήστε μία από τις ακόλουθες μεθόδους:

  • Εγκατάσταση του προγράμματος προβολής αναφορών με δυνατότητα αναδιανομής 2005 Service Pack 1. Για να αποκτήσετε το Report Viewer Redistributable 2005 Service Pack 1, επισκεφθείτε την ακόλουθη τοποθεσία της Microsoft στο Web:
    http://www.microsoft.com/download/details.aspx?familyid=82833F27-081D-4B72-83EF-2836360A904D&displaylang=en

  • Εγκαταστήστε την αθροιστική ενημερωμένη έκδοση πακέτου 9 για SQL Server 2005 Service Pack 2.

    Για περισσότερες πληροφορίες σχετικά με την αθροιστική ενημερωμένη έκδοση πακέτου 9 για SQL Server 2005 Service Pack 2, κάντε κλικ στον αριθμό του άρθρου παρακάτω, για να προβάλετε το άρθρο της Γνωσιακής Βάσης της Microsoft:

    953752 Πακέτο αθροιστικών ενημερώσεων 9 για το SQL Server 2005 Service Pack 2
     

    Εάν εξακολουθείτε να λαμβάνετε το μήνυμα λάθους που αναφέρεται στην ενότητα "Συμπτώματα" μετά την εγκατάσταση του πακέτου αθροιστική ενημερωμένη έκδοση 9, διαγράψτε την κλάση RSClientPrint. Για να το κάνετε αυτό, ακολουθήστε τα παρακάτω βήματα:

    1. Ξεκινήστε τον Windows Internet Explorer.

    2. Στο μενού Εργαλεία, κάντε κλικ στο στοιχείο Επιλογές Internet.

    3. Ακολουθήστε το κατάλληλο βήμα:

      • Στον Windows Internet Explorer 7, κάντε κλικ στην επιλογή Ρυθμίσεις στην περιοχή Ιστορικό περιήγησης και, στη συνέχεια, κάντε κλικ στην επιλογή Προβολή αντικειμένων.
      • Στον Microsoft Internet Explorer 6, κάντε κλικ στην επιλογή Ρυθμίσεις στην περιοχή Προσωρινά αρχεία Internet και, στη συνέχεια, κάντε κλικ στην επιλογή Προβολή αντικειμένων.
    4. Κάντε δεξιό κλικ στο στοιχείο RSClientPrint Class και, στη συνέχεια, κάντε κλικ στην εντολή Κατάργηση (Remove).

Παραπομπές

Για περισσότερες πληροφορίες, επισκεφθείτε την ακόλουθη τοποθεσία της Microsoft στο Web:

http://blogs.msdn.com/mariae/