Συμπτώματα
Αφού ολοκληρώσετε ή ακυρώσετε έναν αποστολέα, η τιμή στο πλαίσιο κατάστασης δεν ενημερώνεται σε κλειστό στη διαχείριση παραγγελιών στο Microsoft Dynamics SL.
ΣημείωσηΤο πλαίσιο κατάστασης εμφανίζεται στην καρτέλα Άλλες πληροφορίες στην οθόνη Αποστολείς (40.110.00). Επιπλέον, η οθόνη "Πρόγραμμα προβολής αρχείων καταγραφής ενημερώσεων αποστολέα" (40.460.00) δεν περιλαμβάνει καταχώρηση για τον κωδικό αποστολέα.
Αιτία
Αιτία 1
Η ρύθμιση Καθυστέρηση ενημέρωσης αποστολέα δεν είναι σωστή. Βλέπε Προτεινόμενη αντιμετώπιση 1.
Αιτία 2
Η ρύθμιση του χρόνου ύπνου για το Process Manager είναι πολύ μικρή. Δείτε την προτεινόμενη αντιμετώπιση 2
Αιτία 3
Το βήμα Ενημέρωση αποστολέα (Update Shipper) στην καρτέλα Βήματα (Steps ) της οθόνης Τύποι παραγγελιών (Order Types) (40.200.00) δεν έχει ρυθμιστεί σωστά. Βλέπε Προτεινόμενη αντιμετώπιση 3.
Αιτία 4
Ο τύπος παραγγελίας άλλαξε στην καρτέλα Βήματα στην οθόνη Τύποι παραγγελιών (40.200.00) πριν κλείσουν οι υπάρχοντες αποστολείς. Βλέπε Προτεινόμενη αντιμετώπιση 4.
Αιτία 5
Προστέθηκαν προσαρμογές στην οθόνη των Φορτωτών (40.110.00) που διέκοψαν την επεξεργασία των εγγραφών του αποστολέα. Βλέπε Προτεινόμενη αντιμετώπιση 5.
Αιτία 6
Οποιαδήποτε άλλη αιτία εκτός από την αιτία 1 έως την αιτία 5. Σε αυτή την περίπτωση, αυτό το ζήτημα παρουσιάζεται ανεξάρτητα από τον τύπο της παραγγελίας. Βλέπε Λύση 6 ή Προτεινόμενη αντιμετώπιση 7.
Επίλυση
Προτεινόμενη αντιμετώπιση 1
Βεβαιωθείτε ότι η ρύθμιση για την καθυστέρηση της ενημέρωσης αποστολέα δεν είναι πολύ μεγάλη. Για να το κάνετε αυτό, ακολουθήστε τα παρακάτω βήματα:
Στο μενού Λειτουργική μονάδα (Module ), κάντε κλικ στην εντολή Διαχείριση παραγγελιών (Order Management).
Στο παράθυρο Διαχείριση παραγγελιών (Order Management ), κάντε κλικ στην επιλογή Ρύθμιση διαχείρισης παραγγελιών (Order Management Setup ) στην περιοχή Εγκατάσταση (Setup).
Στην καρτέλα Άλλες (Other ), βεβαιωθείτε ότι η τιμή στο πλαίσιο Καθυστέρηση ενημέρωσης αποστολέα (λεπτά) (Delay Shipper Update (minutes)) δεν είναι πολύ μεγάλη.
Σημείωση Εάν η τιμή Καθυστέρηση ενημέρωσης αποστολέα (λεπτά) έχει οριστεί σε 30, ο αποστολέας δεν θα κλείσει παρά μόνο 30 λεπτά μετά τη συμπλήρωση της εγγραφής αποστολέα.
Προτεινόμενη αντιμετώπιση 2
Αυξήστε το χρόνο αναστολής λειτουργίας για τη διεργασία διαχείρισης διεργασιών. Για να το κάνετε αυτό, ακολουθήστε τα παρακάτω βήματα:
Στο μενού Λειτουργική μονάδα (Module ), κάντε κλικ στην εντολή Διαχείριση παραγγελιών (Order Management).
Στο παράθυρο Διαχείριση παραγγελιών (Order Management ), κάντε κλικ στην επιλογή Ρύθμιση διαχείρισης παραγγελιών (Order Management Setup ) στην περιοχή Εγκατάσταση (Setup).
Στην καρτέλα Άλλα , πληκτρολογήστε 15 στο πλαίσιο Χρόνος αναστολής λειτουργίας διαχείρισης διεργασιών (δευτερόλεπτα) εάν η τιμή στο πλαίσιο είναι μικρότερη από 15.
Προτεινόμενη αντιμετώπιση 3
Διορθώστε την κατάσταση για το βήμα στον τύπο παραγγελίας. Για να το κάνετε αυτό, ακολουθήστε τα παρακάτω βήματα:
Στη λίστα Λειτουργικές μονάδες , κάντε κλικ στην επιλογή Διαχείριση παραγγελιών.
Στο παράθυρο Διαχείριση παραγγελιών , κάντε κλικ στην επιλογή Τύποι παραγγελιών στην περιοχή Συντήρηση.
Στο πλαίσιο Τύπος παραγγελίας , πληκτρολογήστε το αναγνωριστικό τύπου παραγγελίας που θέλετε να αλλάξετε.
Στην καρτέλα "Βήματα ", κάντε κλικ στην επιλογή "Απαιτείται " στην "Κατάσταση" για το βήμα "Ενημέρωση αποστολέα".
Κάντε κλικ στο κουμπί Αποθήκευση. Στη συνέχεια, κλείστε την οθόνη Τύποι παραγγελιών (40.200.00).
Προτεινόμενη αντιμετώπιση 4
Ακυρώστε τους αποστολείς και τις σχετικές παραγγελίες πώλησης. Για να το κάνετε αυτό, ακολουθήστε τα παρακάτω βήματα:
Στη λίστα Λειτουργικές μονάδες , κάντε κλικ στην επιλογή Διαχείριση παραγγελιών.
Στο παράθυρο Διαχείριση παραγγελιών , κάντε κλικ στην επιλογή Επιβεβαίωση αποστολής στην περιοχή Εισαγωγή.
Στο πλαίσιο Αναγνωριστικό αποστολέα , πληκτρολογήστε το αναγνωριστικό του αποστολέα που θέλετε να ακυρώσετε.
Κάντε κλικ για να επιλέξετε τα ακόλουθα πλαίσια ελέγχου:
- Ακύρωση αποστολέα
- Ακύρωση παραγγελίας
Κάντε κλικ στο κουμπί Τέλος. Στη συνέχεια, κλείστε την οθόνη επιβεβαίωσης αποστολής (40.117.00).
Προτεινόμενη αντιμετώπιση 5
Καταργήστε τις προσαρμογές για την οθόνη "Αποστολείς(40.110.00) ". Για να το κάνετε αυτό, ακολουθήστε τα παρακάτω βήματα:
Κλείστε όλες τις οθόνες εκτός από την οθόνη Αποστολείς (40.110.00).
Στο μενού Προσαρμογή (Customize ), κάντε κλικ στην εντολή Προσαρμογή κατάστασης λειτουργίας (Customize Mode).
Στο μενού Προσαρμογή (Customize ), κάντε κλικ στην εντολή Κατάργηση αλλαγών για την οθόνη (Remove Changes For Screen).
Κάντε κλικ στο κουμπί Ναι και, στη συνέχεια, κάντε κλικ στο κουμπί OK.
Κλείστε την οθόνη "Αποστολείς" (40.110.00). Στη συνέχεια, ανοίξτε την οθόνη.
Προτεινόμενη αντιμετώπιση 6
Αλλάξτε τη σειρά των αποστολέων με μια παραγγελία που αναγνωρίζεται από το Process Manager. Για να το κάνετε αυτό, ακολουθήστε τα εξής βήματα.
Σημείωση Πριν ακολουθήσετε τις οδηγίες σε αυτή τη διαδικασία, βεβαιωθείτε ότι έχετε ένα πλήρες αντίγραφο ασφαλείας της βάσης δεδομένων, το οποίο μπορείτε να επαναφέρετε εάν παρουσιαστεί πρόβλημα.
Στην οθόνη Διαχείριση διεργασιών (40.400.00), κάντε κλικ στο κουμπί Διακοπή.
Χρησιμοποιώντας το Microsoft SQL Query Analyzer ή το Microsoft SQL Server Management Studio, εκτελέστε την κατάλληλη πρόταση στη βάση δεδομένων της εφαρμογής.
-
Microsoft SQL Server 7.0
Σημείωση
SELECT "execADG_Release_For_Update '" + rtrim(CpnyID) + "', '', '" +rtrim(ShipperID) + "'" από το SOSHIPHEADER όπου NextFunctionID ="4043000" και NextFunctionClass = "0200"
Microsoft SQL Server 2000 ή Microsoft SQL Server 2005 ή Microsoft SQL Server 2008
Σημείωση
SET QUOTED_IDENTIFIEROFF SELECT "exec ADG_Release_For_Update '" + rtrim(CpnyID) + "','', '" + rtrim(ShipperID) + "'" από το SOSHIPHEADER whereNextFunctionID = "4043000" and NextFunctionClass = "0200"
Αντιγράψτε τα αποτελέσματα της πρότασης σε ένα νέο παράθυρο. Εξαιρέστε τυχόν επικεφαλίδες στηλών ή γραμμές πλήθους γραμμών. Στη συνέχεια, εκτελέστε τη νέα πρόταση για να τοποθετήσετε εκ νέου τους αποστολείς που παρατίθενται στη σειρά.
Σημείωση Η ακόλουθη πρόταση αποτελεί παράδειγμα των αποτελεσμάτων που θα αντιγράψετε.
Σημείωση
Exec ADG_Release_For_Update '0060', '', 'S0009868'
Στην οθόνη Διαχείριση διεργασιών (40.400.00), κάντε κλικ στο κουμπί Έναρξη.
Προτεινόμενη αντιμετώπιση 7
Ακυρώστε τον αποστολέα. Για να το κάνετε αυτό, ακολουθήστε τα παρακάτω βήματα:
Στη λίστα Λειτουργικές μονάδες , κάντε κλικ στην επιλογή Διαχείριση παραγγελιών.
Στο τμήμα παραθύρου Διαχείριση παραγγελιών , κάντε κλικ στην επιλογή Αποστολείς στην περιοχή Εισαγωγή.
Στην καρτέλα Άλλες πληροφορίες (Other Information ), κάντε κλικ για να επιλέξετε το πλαίσιο ελέγχου Ακυρωμένο (Cancelled ) και, στη συνέχεια, κάντε κλικ στο κουμπί Τέλος (Finish).