Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

When you run Perfmon.exe with the Active Directory Diagnostics template to generate a report on a Windows Server 2008-based domain controller, the process may stop responding.

Cause

This issue occurs because the Reliability and Performance Monitor (Perfmon.exe) console that is running the TraceRpt.exe tool consumes too much memory and CPU resources during the report generation process. If the Windows Server 2008-based server is really busy and lacks resources, the report generation process will stop responding.

Resolution

To resolve this issue, copy your files to a different computer that has same server role and that has enough hardware resources. Then, run TraceRpt.exe with the files. To do this, follow these steps:

  1. In the Reliability and Performance Monitor (Perfmon.exe) console, click Data Collector Sets, and then click
    System.

  2. Right-click Active Directory Diagnostics, and then click Start. The file collection process starts on the Windows Server 2008-based domain controller.

  3. After the report status changes to generating report from collecting data for
    <time>
    , copy the files to the second Windows Server 2008-based domain controller.

    Note You can find the files at the following location:

    %systemdrive%\Perflogs\ADDS\date report generation run\*

    Note Ths "-df" switch is to specify the Microsoft specific counting/reporting schema file that is generated with the Perfmon. This file name is named report.xsl

  4. Locate the files, and then run the following command at the command line on the second Windows Server 2008-based domain controller:

    tracerpt *.blg *.etl -df PerfmonSchemaFileName.xsl -report your_report.html -f html
  5. Use Windows Internet Explorer to view the .html file that is generated.

More Information

To review the Performance and Reliability Monitoring Step-by-Step guide for Windows Server 2008, visit the following Microsoft Web site:

http://technet.microsoft.com/en-us/library/cc771692.aspx

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×