Symptoms

Support package creation fails when running Export-HcsSupportPackage with error "Could not find part of the path"Example: [SSS0991003L7054]: Controller1>Export-HcsSupportPackage -Path \\10.3.26.93\dump -Credential administratorWARNING: A script or application on the remote computer SSS991003L7054 is sending a prompt request. When you areprompted, enter sensitive information, such as credentials or passwords, only if you trust the remote computer and theapplication or script that is requesting the data. cmdlet Export-HcsSupportPackage at command pipeline position 1Supply values for the following parameters:EncryptionPassphrase: ******WARNING: A script or application on the remote computer SSS0991003L7054 is sending a prompt request. When you areprompted, enter sensitive information, such as credentials or passwords, only if you trust the remote computer and theapplication or script that is requesting the data.Confirm EncryptionPassphrase: ******12/11/2015 10:57:26 AM Connecting to '\\10.3.26.93\dump'12/11/2015 10:57:26 AM Initiating peer data collection12/11/2015 10:57:28 AM ClusterManagementLog element has been gathered.12/11/2015 10:57:28 AM DumpLog element has been gathered.12/11/2015 10:57:28 AM StackDumps element has been gathered.12/11/2015 10:57:28 AM PeriodicEtwLogs element has been gathered.12/11/2015 10:57:34 AM BmcLogs element has been gathered.12/11/2015 10:57:38 AM RegistryKeys element has been gathered.12/11/2015 10:57:39 AM ClusterCmdlets element has been gathered.12/11/2015 10:57:39 AM NetworkCmdlets element has been gathered.12/11/2015 10:57:39 AM NetworkCmds element has been gathered.12/11/2015 10:57:39 AM Rttdump element has been gathered.12/11/2015 10:57:40 AM LogFiles element has been gathered.12/11/2015 10:57:40 AM StorageCmdlets element has been gathered.12/11/2015 10:57:46 AM XutilLogdump element has been gathered.Export-HcsSupportPackage : An error occurred while gathering the ClusterLog element of the support package. Could notfind a part of the path.    + CategoryInfo          : NotSpecified: (:) [Export-HcsSupportPackage], Exception    + FullyQualifiedErrorId : An error occurred while gathering the ClusterLog element of the support package.,Microso   ft.HCS.Management.Powershell.Cmdlets.ExportHcsSupportPackageCommand 12/11/2015 10:59:51 AM EtwLogs element has been gathered.12/11/2015 11:01:53 AM XutilDdump element has been gathered.12/11/2015 11:02:21 AM ConfigurationCmdlets element has been gathered.12/11/2015 11:02:21 AM Finishing peer data collectionWARNING: The operation succeeded on this controller, but failed on the peer controller due to the following error(s).Please check whether the peer is healthy and whether the current node can connect to the peer.Export-HcsSupportPackage : Could not find a part of the path'D:\hcs\temp\supportpkg_4fr2znln.tjs\HKEY_LOCAL_MACHINE-Software-Microsoft-CisAgent.txt'.    + CategoryInfo          : NotSpecified: (:) [Get-HcsSupportPackage], DirectoryNotFoundException    + FullyQualifiedErrorId : An error occurred while placing the file 'registry\HKEY_LOCAL_MACHINE-Software-Microsoft   -CisAgent.txt'.,Microsoft.HCS.Management.Powershell.Cmdlets.GetHcsSupportPackageCommand Export-HcsSupportPackage : An error occurred while gathering 'C:\Program Files\LSI\RTTDump.exe' for the Rttdumpelement of the support package. Could not find a part of the path 'D:\hcs\temp\supportpkg_mbyu3z3v.dud'.    + CategoryInfo          : NotSpecified: (:) [Get-HcsSupportPackage], Exception    + FullyQualifiedErrorId : An error occurred while gathering the Rttdump element of the support package.,Microsoft.   HCS.Management.Powershell.Cmdlets.GetHcsSupportPackageCommand Export-HcsSupportPackage : An error occurred while gathering the ClusterLog element of the support package. Could notfind a part of the path.    + CategoryInfo          : NotSpecified: (:) [Get-HcsSupportPackage], Exception    + FullyQualifiedErrorId : An error occurred while gathering the ClusterLog element of the support package.,Microso   ft.HCS.Management.Powershell.Cmdlets.GetHcsSupportPackageCommand Export-HcsSupportPackage : An error occurred while gathering 'HKEY_LOCAL_MACHINE\Software\Microsoft\CDMInfra' for theRegistryKeys element of the support package. The operation was canceled.    + CategoryInfo          : NotSpecified: (:) [Get-HcsSupportPackage], Exception    + FullyQualifiedErrorId : An error occurred while gathering the RegistryKeys element of the support package.,Micro   soft.HCS.Management.Powershell.Cmdlets.GetHcsSupportPackageCommand \\10.3.26.93\dump\8100-SSS0991003L7054-151211-1057

Cause

Timing issue with periodic log collection or another support package being created by another process. There is a background process on the appliance that periodically copies log files and moves them to a temporary location on the appliance. This process tries to access the files at the same time as Export-HcsSupportPackage.

Resolution

Since it is a timing issue, please wait a few minutes and retry. Update 2.2 improves the user experience so that there is a clear error message in this case: "Log archiving in progress or another support package is being generated. Please try again later." If retry does not work after 10 minutes, contact support.

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