Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Consider the following scenario:

  • You have a computer that is running Windows Server 2008 R2 or Windows 7.

  • You run an application or a service that calls the FaxEnumJobs function to query fax jobs that are on a FAX server.

In this scenario, the FaxEnumJobs function does not return all the fax jobs. The function returns only the fax jobs of the current user account.

For example, an administrator account can view only the fax jobs of the administrator account.

Cause

This issue occurs because the FaxEnumJobs function enumerates only the fax jobs that are owned by the current user account.

Resolution

To resolve this issue, grant the user account that has to enumerate all the fax jobs the View Outgoing Fax Jobs permission after you install this hotfix. To do this, follow these steps

  1. Open Control Panel.

  2. Click Hardware and Sound.

  3. Click Devices and Printers.

  4. Double-click the Fax device to open the Windows Fax and Scan windows

  5. On the Tools menu, click Fax Settings.

  6. Click the Security tab, and then click Advanced.

  7. Select the user account that you want to grant the View Outgoing Fax Jobs permission, and then click Edit.

  8. Click to select the View outgoing fax jobs check box under Allow.

  9. Click OK to apply the permission.



Warning After a user installs this hotfix, the user can view the outgoing fax jobs of other users if the user installs this hotfix by using a user account that has the View outgoing fax jobs permission. To avoid this situation, you must review the View outgoing fax jobs permission for all users.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:

  • Windows 7

  • Windows Server 2008 R2

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 7 and Windows Server 2008 R2 file information notes


Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows 7

File name

File version

File size

Date

Time

Platform

Fxsevent.dll

6.1.7600.16385

7,680

14-Jul-2009

01:05

x86

Fxsmon.dll

6.1.7600.16385

38,912

14-Jul-2009

01:15

x86

Fxsroute.dll

6.1.7600.16385

67,072

14-Jul-2009

01:15

x86

Fxssvc.exe

6.1.7600.20741

522,752

23-Jun-2010

07:53

x86

Fxsunatd.exe

6.1.7600.16385

19,968

14-Jul-2009

01:14

x86

For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Fxsevent.dll

6.1.7600.16385

7,680

14-Jul-2009

01:27

x64

Fxsmon.dll

6.1.7600.16385

41,472

14-Jul-2009

01:40

x64

Fxsroute.dll

6.1.7600.16385

82,944

14-Jul-2009

01:40

x64

Fxssvc.exe

6.1.7600.20741

689,152

23-Jun-2010

08:13

x64

Fxsunatd.exe

6.1.7600.16385

17,920

14-Jul-2009

01:39

x64

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about the FaxEnumJobs function, visit the following Microsoft website:

General information about the "FaxEnumJobs" function

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7

File name

Update.mum

File version

Not applicable

File size

1,844

Date (UTC)

24-Jun-2010

Time (UTC)

07:46

Platform

Not applicable

File name

X86_f71519f29b3508dd2cf761269275b905_31bf3856ad364e35_6.1.7600.20741_none_028b3eda710aa399.manifest

File version

Not applicable

File size

699

Date (UTC)

24-Jun-2010

Time (UTC)

07:46

Platform

Not applicable

File name

X86_microsoft-windows-fax-service_31bf3856ad364e35_6.1.7600.20741_none_adaad0e5fa9dc401.manifest

File version

Not applicable

File size

50,121

Date (UTC)

24-Jun-2010

Time (UTC)

07:49

Platform

Not applicable

Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

Amd64_90f11c9c7677486b0fbe2de8a8ba171f_31bf3856ad364e35_6.1.7600.20741_none_b235a65f9217f715.manifest

File version

Not applicable

File size

1,048

Date (UTC)

24-Jun-2010

Time (UTC)

07:46

Platform

Not applicable

File name

Amd64_microsoft-windows-fax-service_31bf3856ad364e35_6.1.7600.20741_none_09c96c69b2fb3537.manifest

File version

Not applicable

File size

50,125

Date (UTC)

24-Jun-2010

Time (UTC)

07:46

Platform

Not applicable

File name

Update.mum

File version

Not applicable

File size

2,056

Date (UTC)

24-Jun-2010

Time (UTC)

07:46

Platform

Not applicable

File name

Wow64_microsoft-windows-fax-service_31bf3856ad364e35_6.1.7600.20741_none_141e16bbe75bf732.manifest

File version

Not applicable

File size

22,666

Date (UTC)

23-Jun-2010

Time (UTC)

08:17

Platform

Not applicable

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×