Symptoms
When Exchange Server 2013 is installed on Microsoft Windows Server 2012, Outlook Web App cannot prompt a user to change an expired password in an Exchange Server 2013 environment.
For example, you create a new user, and you select the User must change the password at the next logon option. When the user tries to log on to Outlook Web Access by using the user name and password, they keep receiving the following error message:
The user name or password you entered isn't correct. Try entering it again.
The expected behavior is for Outlook Web App to prompt the user to change their expired password.
Cause
This issue occurs because Outlook Web App cannot find the necessary setting, and therefore it disables password reset.
Resolution
To resolve this issue, install the Exchange Server 2013 Service Pack 1:
2926248 Description of Exchange Server 2013 Service Pack 1