Symptoms
You can't connect to a server that is running Microsoft Exchange Server from either a Microsoft Outlook 2019 for Mac or Outlook for Mac for Office 365 client after disabling Secure Sockets Layer (SSL) on the server.
Cause
The connection failure occurs because Outlook for Mac uses SSL to establish communication with an Exchange server. When SSL is disabled and secure renegotiation is implemented as defined in RFC 5746, Outlook requires the server to be in Compatible mode so that the session can be renegotiated from SSL to Transport Layer Security (TLS).
Workaround
Configure the Exchange server to support Compatible mode by using the instructions from KB article 980436. This mode allows the Outlook for Mac client to establish a connection by using the SSL protocol and then renegotiate by using TLS. By using this method, Outlook for Mac can connect to the server even when SSL 2.0 and 3.0 are blocked. If you're using a security product such as Microsoft Forefront Threat Management Gateway (TMG) for managing connections to Exchange Server from outside your company, you will need to configure your TMG server using KB article 980436. External connections to Exchange Server may be blocked if the TMG server is in Strict mode.
Note: Do not configure the TMG server to use Strict mode, as this prevents the Outlook for Mac client from connecting to Exchange Server.
More Information
For more information about SSL/TLS Renegotiation, review this TechNet blog post.