How to reduce the chances of macro virus infection in Word

Summary

This article describes ways you can reduce the risk of infecting Microsoft Word and your documents and templates with macro viruses.

More Information

It is recommended that you use one or more of the following methods to help reduce the possibility of macro virus infection.


Note No one method of protection is a total guarantee that your installation of Microsoft Word will not be affected by a macro virus.

Method 1: Install and update antivirus software

For a long-term solution to macro viruses, install antivirus software that is specifically designed to detect macro viruses.


Note After you install an antivirus software program, you must keep it updated to ensure that new macro viruses are detected and removed. For more information about updating your antivirus software program, please contact your antivirus software vendor.


For more information about hardware and software vendor contact information, visit the following Microsoft Web site:
http://support.microsoft.com/gp/vendors

Method 2: Set a security level in Microsoft Word

Microsoft Word offers the following levels of security to reduce the chances that a macro virus will infect your documents, templates, or add-ins.




Follow these steps in Microsoft Word to change the security level:
  1. On the Tools menu, point to Macro, and then click Security.
  2. On the Security Level tab, select the security level that you want, and then click OK.

Method 3: Lock the global template (Normal.dot)

Follow these steps to lock your global template (Normal.dot) with a password to reduce the possibility of unauthorized access by a macro virus:
  1. On the Tools menu, point to Macro, and then click Visual Basic Editor.
  2. In the Visual Basic Editor, click to select This Document in the Project window.


    Note If the Project window does not appear, click Project Explorer on the View menu.
  3. On the Tools menu, click Project Properties.
  4. On the Protection tab, click to select the Lock project for viewing check box.
  5. Type a password in the Password box.
  6. Type the same password in the Confirm password box.
  7. Click OK.
  8. On the File menu, click Close and return to Microsoft Word.
  9. In Microsoft Word, hold SHIFT and click Save All on the File menu.
  10. If the following message appears, click Yes.
    Changes have been made that affect the global template, Normal.dot. Do you want to save those changes?

References

For more information about what to do if you think your computer might be infected with a Word macro virus, click the following article number to view the article in the Microsoft Knowledge Base:

211800 How to deal with a macro virus in Word 2000 or Word 2002

For more information about macro viruses, please see the following Microsoft Web sites:

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.
Properties

Article ID: 233396 - Last Review: Jun 9, 2009 - Revision: 1

Feedback