Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Important Before you run this the Fix It, save your data, and close the application. After you run the Fix It, your computer will restart after 10 minutes.

Symptoms

On a computer that's running Windows XP, Windows Vista, or Windows 7, some icons in the following locations are randomly changed to other icons:

  • My Computer

  • Windows Explorer

  • Desktop

  • Quick Launch bar

Cause

This issue occurs because the icon cache is not updated correctly.

Resolution

To fix the issue, the first step is to log on to another user account that has administrator rights. To do this, follow these steps:

  1. Log off the current user account that encounters the icon change.

  2. Log on as a user who has administrator rights.

Note The file must be deleted by another user because during the logoff process, the IconCache.db file may be overwritten with the corrupted icon data.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 How to back up and restore the registry in Windows

Then follow these steps to fix the issue:

  1. If a Close Open Programs Interaction dialog box is displayed, close all open windows.

  2. Create the Max Cached Icons registry key, and then set the value of that key to 2048. To do this, follow these steps:

    1. Click Start, type regedit in the Search box, and click Regedit in the list that's displayed.

    2. Locate and select the following registry key:

      HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer

    3. On the Edit menu, click New, and then click String Value.

    4. Type MaxCachedIcons for the registry key name, and then press Enter.

    5. Double-click the Max Cached Icons registry key, enter 2048 in the Value data box, and then click OK.

    6. Exit Registry Editor.

  3. Delete IconCache.db from the following location, depending on your operating system.

    Windows XP

    C:\Documents and Settings\<User Name>\Local Settings\Application Data

    Windows Vista or Windows 7

    C:\Users\<User Name>\AppData\LocalNote <User Name> is a placeholder for the name of the user account that encounters the icon change.

More Information

How the MATS package works to fix this problem

  1. The MATS package scans your computer and then detects whether the computer is running Windows XP, Windows Vista, or Windows 7.

  2. The MATS package determines whether or not the Max Cached Icons registry value in the registry subkeys exists. If the Max Cached Icons registry value does not exist, create it, and then set it to 2048. If the Max Cached Icons registry value exists, set it to 2048.

    Note During this process, a dialog box appears. This gives you the option to fix the issue automatically (this is the recommended option) or to manually select individual issues to fix. If you manually select individual issues to fix, you must select the Icon and folder customizations or Others or I don't know option in the dialog box.

  3. The MATS package verifies that the IconCache.db file has been deleted successfully.

Other issues that the MATS package fixes

2394521 Can't empty the Recycle Bin in Windows XP or in Windows Vista

949109 "The file or folder does not exist" error in Windows Vista

934160 "Network or file permission" or "folder does not exist" error

2394740 Can't select multiple items after upgrading from Windows XP to Windows Vista

813711 Changes to the size, view, icon or position of a folder are lost

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×