Recipient’s email address is resolved incorrectly to a contact’s email address in an Exchange Server 2010 environment

Applies to: Microsoft Exchange Server 2010 Service Pack 2Exchange Server 2010 EnterpriseExchange Server 2010 Standard

Symptoms


Consider the following scenario:
  • You have a user (use A) whose email address contains a hyphen (-) in a Microsoft Exchange Server 2010 environment.
  • You create a contact that contains a hyphen. The email address of the contact resembles the email address of user A.
  • You create an email message by using Outlook Web App.
  • You type the email address of user A in the To, Cc, or Bcc box.
  • You click the Check Names button.
In this scenario, the email address that you typed is resolved incorrectly to the email address of the contact. Therefore, you send the email message to the wrong recipient unintentionally.

For example, user A’s email address is y-abc@example.com. The contact’s email address is m-abc@example.com. You type y-abc@example.com in Outlook Web App. Then, you click the Check Names button. In this situation, the email address is resolved incorrectly to m-abc@example.com instead of y-abc@example.com.

Cause


This issue occurs because Outlook Web App uses hyphens as word-breakers. Therefore, Ambiguous Name Resolution (ANR) performs ambiguous matching for the email address, and then selects the incorrect email address.

Resolution


To resolve this issue, install the following update rollup:
2706690 Description of Update Rollup 4 for Exchange Server 2010 Service Pack 2

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.