Cluster node freezes when you restart a computer in a Windows Server 2008 R2 or Windows Server 2012 environment

Applies to: Windows Server 2008 R2 DatacenterWindows Server 2008 R2 EnterpriseWindows Server 2008 R2 for Itanium-Based Systems More

Symptoms


Consider the following scenario:
  • You deploy a failover cluster in a Windows Server 2008 R2 or Windows Server 2012 environment.
  • You enable the Volume Shadow Copy Service on a cluster disk.
  • You replace a host bus adapter (HBA) on a cluster node.
  • You restart the cluster node.
In this scenario, the cluster node freezes.

Cause


This issue is triggered by a deadlock that occurs when the computer restarts.

Resolution


Update information for Windows Server 2012

To resolve this issue in Windows Server 2012, install update rollup 2855336. For more information about how to obtain this update rollup package, click the following article number to view the article in the Microsoft Knowledge Base:
2855336 Windows RT, Windows 8, and Windows Server 2012 update rollup: July 2013

Hotfix information for Windows Server 2008 R2

To resolve this issue in Windows Server 2008 R2, install the hotfix that is described in this article.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows Server 2008 R2 Service Pack 1 (SP1). For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to change the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about the fix for this issue in Windows Server 2008, click the following article number to view the article in the Microsoft Knowledge Base:
2706774 Cluster nodes stop responding in a Windows Server 2008 environment