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Symptoms

Consider the following scenario:

  • You create a Windows Server 2012-based failover cluster by using third-party dynamic disk resources.

  • You configure a File Server service resource in the Failover Cluster Management snap-in.

  • You try to add a cluster file share to the File Server service resource by using the Add File Share shortcut menu or the Actions pane.

In this scenario, the following issues occur:

  • The New Share Wizard does not start from either the shortcut menu or the Actions pane.

  • You cannot create the cluster file share by using a Windows PowerShell command, the NetShare API, or File Explorer. For more information about this issue, click the following article number to view the article in the Microsoft Knowledge Base:

    2796000 You cannot create a cluster file share on a third-party dynamic disk resource in Windows Server 2012

Cause

This issue occurs because the Failover Cluster Management snap-in in Windows Server 2012 assumes an incorrect order of the resources in the File Server role.

Resolution

Hotfix information


Examples of products that leverage third-party storage class resources which you should apply this hotfix if you are using these products include (but is not limited to):

  • Symantec Storage Foundation for Windows

  • Vision Solutions Double-Take Availability

  • SIOS DataKeeper Cluster Edition


To resolve these issues, install the hotfix on a Windows Server 2012-based cluster node or on a Windows 8-based computer that has the Remote Server Administration Tools for Windows 8 installed. Additionally, install the hotfixes that are described in KB 2796000 and KB 2795997 to resolve all the related issues. For more information about KB 2796000 and KB 2795997, click the following article numbers to view the articles in the Microsoft Knowledge Base:

2796000 You cannot create a cluster file share on a third-party dynamic disk resource in Windows Server 2012

2795997 UI is displayed incorrectly when you right-click a third-party dynamic disk resource in the Available Storage area in Windows Server 2012
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012 or Windows 8 that has the Remote Server Administration Tools for Windows 8 installed.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.





Windows 8 and Windows Server 2012 file information notesImportant Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.2.920 0.20 xxx

    Windows 8 and Windows Server 2012

    RTM

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 8 and Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows 8

File name

File version

File size

Date

Time

Platform

Microsoft.failoverclusters.framework.dll

6.2.9200.16493

1,336,320

04-Jan-2013

13:21

x86

Microsoft.failoverclusters.framework.dll

6.2.9200.20598

1,336,320

04-Jan-2013

12:36

x86

For all supported x64-based versions of Windows 8 and of Windows Server 2012

File name

File version

File size

Date

Time

Platform

Microsoft.failoverclusters.framework.dll

6.2.9200.16493

1,336,320

04-Jan-2013

13:21

x64

Microsoft.failoverclusters.framework.dll

6.2.9200.20598

1,336,320

04-Jan-2013

12:36

x64




Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Additional file information

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