Can't access VNN FILESTREAM share when you use the FILESTREAM and FileTable features on a Windows Server 2012-based failover cluster

Applies to: Windows Server 2012 EssentialsWindows Server 2012 DatacenterWindows Server 2012 Datacenter

Symptoms




Consider the following scenario:
  • You have a Microsoft SQL Server 2012 database that contains FILESTREAM data and FileTables.
  • The database is in an AlwaysOn Availability Group that is hosted on a Windows Server 2012-based failover cluster.
  • You create an availability group listener for the Availability Group.
  • You check whether you can access a VNN FILESTREAM share that has the primary replica of the availability group by using Virtual Network Name in the following format:
    \\<VNN>\<filestream_share_name>
In this scenario, you cannot access the share because the VNN FILESTREAM share creation fails.

Note When you access the share by using the name of the node that has the primary replica of the Availability Group, all files are visible in the share.

Cause


This issue occurs because the FILESTREAM driver is not recognized as a cluster disk when located on a cluster.

Resolution


This hotfix is also available at Microsoft Update Catalog

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

More Information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

References


For more information about using the FILESTREAM and FileTable features together with AlwaysOn Availability Groups, go to the following MSDN website: