The 802.11n mode of a third-party wireless network adapter is not used when FIPS mode is enabled on a computer that is running Windows 7 Service Pack 1

Applies to: Windows 7 Service Pack 1Windows 7 EnterpriseWindows 7 Home Basic More

Symptoms


You have a Windows 7 Service Pack 1-based computer that uses a third-party 802.11n wireless network adapter. When you enable Federal Information Processing Standards (FIPS) mode for the adapter, the third-party adapter reverts to 802.11g mode instead of 802.11n mode.

Cause


This problem occurs because the following features are not supported when you use a third-party 802.11n network adapter in FIPS mode:
  • Quality of Service (QoS) priority tagging
  • Aggregated MAC Service Data Unit (A-MSDU) de-aggregation

Resolution


To resolve this problem, upgrade the third-party 802.11n wireless network adapter to a driver that supports the features that are mentioned in the "Cause" section (QoS priority tagging and A-MSDU de-aggregation) in FIPS mode, and then apply the hotfix that is described in this section.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 Service Pack 1 (SP1). For information about how to obtain Windows 7 Service Pack 1, see Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2 .

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.