Applies ToWindows 8 Windows 8 Enterprise Windows 8 Pro Windows Server 2012 Datacenter Windows Server 2012 Datacenter Windows Server 2012 Essentials Windows Server 2012 Foundation Windows Server 2012 Foundation Windows Server 2012 Standard Windows Server 2012 Standard

Symptoms

Consider the following scenario:

  • You have a computer that is running Windows 8 or Windows Server 2012.

  • You print a file by using a 32-bit application.

  • The print job is finished successfully.

In this scenario, the Splwow64.exe process does not immediately end.Note The Splwow64.exe process is used to translate the driver model of a 64-bit operating system and a 32-bit program. Splwow64.exe is used to support the Printer Driver Isolation feature. The 32-bit version of Windows 8 has its own Splwow64.exe file, and the 32-bit version of Splwow64.exe is also affected by this issue. For more information about application isolation, see the following MSDN website:

http://msdn.microsoft.com/en-us/library/windows/desktop/jj156033.aspx

Cause

This issue occurs because the Splwow64.exe process stays in memory for longer than necessary in order to increase system performance after a print job is finished.

Resolution

This hotfix is also available at Microsoft Update Catalog.After you apply this hotfix, the hotfix sets the default time-out value for the Splwow64.exe process to remain in memory to two minutes. Therefore, the Splwow64.exe process ends two minutes after the last print job is finished. Additionally, you can configure this time-out value by changing the registry value. To configure the time-out value, follow these steps: Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 How to back up and restore the registry in Windows

  1. Swipe in from the right edge of the screen, and then tap Search. Or, if you are using a mouse, point to the lower-right corner of the screen, and then click Search.

  2. In the search box, type regedit, and then tap or click regedit.

    UAC If you are prompted to enter an administrator password, type the password. If you are prompted to provide confirmation, provide confirmation.

  3. Locate and then tap or click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print

  4. On the Edit menu, point to New, and then tap or click DWORD Value.

  5. Type SplWOW64TimeOutSeconds.

  6. Press and hold or right-click SplWOW64TimeOutSeconds, and then tap or click Modify.

  7. In the Value data box, enter a value, and then tap or click OK.

  8. Exit Registry Editor.

Note You must enter a value that is greater than zero in the Value data box. The value that you enter is the seconds that the system periodically waits while it checks whether the Splwow64.exe process is unloaded. This behavior occurs when that same number of seconds elapses after the last 32-bit print process has closed. Therefore, when a service process prints, the print capability is not released until the service closes, and at least the time that you specify in the Value data box has passed. For example, if you type 15 in the Value data box, and the last 32-bit process takes two minutes to print and then close, the print capability is released between two minutes 15 seconds and two minutes 30 seconds. If no time-out value is specified, the default time-out value is two minutes.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 8 or Windows Server 2012.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 8 and Windows Server 2012 file information notesImportant Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.2.920 0.16 xxx

    Windows 8 and Windows Server 2012

    RTM

    GDR

    6.2.920 0.20 xxx

    Windows 8 and Windows Server 2012

    RTM

    LDR

  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 8 and Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows 8

File name

File version

File size

Date

Time

Platform

Splwow64.exe

6.2.9200.20738

109,056

07-Jun-2013

03:58

x86

Spoolsv.exe

6.2.9200.16384

496,640

26-Jul-2012

03:20

x86

For all supported x64-based versions of Windows 8 and of Windows Server 2012

File name

File version

File size

Date

Time

Platform

Service branch

Splwow64.exe

6.2.9200.20738

126,464

07-Jun-2013

06:58

x64

AMD64_MICROSOFT-WINDOWS-PRINTING-SP

Spoolsv.exe

6.2.9200.20738

769,024

07-Jun-2013

06:58

x64

AMD64_MICROSOFT-WINDOWS-PRINTING-SP

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about the similar issue, click the following article numbers to view the articles in the Microsoft Knowledge Base:

2815716 Splwow64.exe process doesn't end after a print job finishes in the 64-bit version of Windows 7 or Windows Server 2008 R2

972616 You cannot use the "runas" command to print from different user accounts in a single session from a 32-bit program on a computer that is running 64-bit version of Windows Server 2008 or Windows Vista For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows 8 and Windows Server 2012

Additional files for all supported x86-based versions of Windows 8

File name

X86_e34daac0d2b6d45e84ab8ebeed6de725_31bf3856ad364e35_6.2.9200.20738_none_75e00f9569a9cc12.manifest

File version

Not applicable

File size

709

Date (UTC)

10-Jun-2013

Time (UTC)

10:50

Platform

Not applicable

File name

X86_microsoft-windows-printing-spooler-core_31bf3856ad364e35_6.2.9200.20738_none_d3ba6243abe0fabd.manifest

File version

Not applicable

File size

242,005

Date (UTC)

10-Jun-2013

Time (UTC)

10:50

Platform

Not applicable

Additional files for all supported x64-based versions of Windows 8 and of Windows Server 2012

File name

Amd64_microsoft-windows-printing-spooler-core_31bf3856ad364e35_6.2.9200.20738_none_2fd8fdc7643e6bf3.manifest

File version

Not applicable

File size

242,555

Date (UTC)

07-Jun-2013

Time (UTC)

21:33

Platform

Not applicable

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