Stop error 0x139 in Windows Server 2012 when the thin provisioning threshold is crossed

Applies to: Windows Server 2012 DatacenterWindows Server 2012 DatacenterWindows Server 2012 Standard

Symptoms


You have a Windows Server 2012-based computer that hosts thin provisioning storage and has the thin provisioning threshold configured. When data is written to the storage after the thin provisioning threshold is crossed, the computer crashes and you receive the following error:
STOP: 0x00000139 (parameter1, parameter2, parameter3, parameter4)
Notes
  • This error indicates that the kernel has detected the corruption of a critical data structure.
  • The parameters in this stop error message vary, depending on the configuration of the computer.
  • Not all 0x00000139 errors are caused by this problem.

Cause


The problem occurs because the storage stack is corrupted.

Resolution


To resolve this problem, install update rollup 2862768, or apply the hotfix that is described in this article. This hotfix is also available at Microsoft Update Catalog.

Update information

For more information about how to obtain update rollup 2862768, click the following article number to go to the article in the Microsoft Knowledge Base:
2862768 Windows RT, Windows 8, and Windows Server 2012 update rollup: August 2013

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates