FIX: Outlook displays "Trying to Connect" or "Disconnected" when it tries to connect to Office 365 Exchange servers on a computer that is running Windows 7 or Windows Server 2008 R2

Vrijedi za: Windows 7 EnterpriseWindows 7 ProfessionalWindows 7 Ultimate

Symptoms


Assume that you use Microsoft Office 365 on a computer that is running Windows 7 or Windows Server 2008 R2. When you use Microsoft Outlook to connect to Office 365 Exchange servers, you notice that Outlook displays "Trying to Connect" or "Disconnected" for anywhere from five minutes to more than one hour.

Cause


This problem occurs because individual function calls in the remote procedure call (RPC) over the HTTP connection takes too much time to return. Additionally, these calls are piled up in heavy-load scenarios. The pile-up causes each call to return after a long time.

Resolution


Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Service Pack 1 for Windows 7 or Windows Server 2008 R2 installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.