FIX: Stop error 0x133 or 0x9E occurs when WHEA record is not acknowledged by SMI in Windows

Kehtib: Windows Server 2012 DatacenterWindows Server 2012 DatacenterWindows Server 2012 Standard

Symptoms


On a computer that is running Windows 8, Windows Server 2012, Windows 7 Service Pack 1 (SP1), or Windows Server 2008 R2 SP1, you receive a Stop error message that resembles the following:

STOP: 0x00000133 (parameter1, parameter2, parameter3, parameter4)
DPC_WATCHDOG_VIOLATION

After you receive this Stop error message, the computer restarts automatically. In the resulting memory dump file, the stack of the failing kernel thread may indicate one of the following routines:
  • PSHED!PshedpWaitForOperationToComplete
  • hal!HalpCmcPollProcessor

Note There are many possible causes of the DPC_WATCHDOG_VIOLATION Stop error 0x00000133. This particular occurrence is rare. It occurs only on certain systems that meet the conditions that are described in the "Cause" section.

Additionally, on a Windows Server 2008 R2 SP1-based failover cluster or a Windows Server 2012-based failover cluster, you may receive a Stop error message that resembles the following:
STOP: 0x0000009E (parameter1, parameter2, parameter3, parameter4)

Notes
  • The parameters in the Stop error message vary, depending on the configuration of the computer.
  • Not all "0x0000009E" errors are caused by this problem.

Cause


This problem may occur on systems in which the following conditions are true:
  • The following command types are run:
    • Windows Hardware Error Architecture (WHEA) (Corrected Machine Check)
    • Processor Clocking Control (PCC) / ACPI processor power management (PPM)
  • Both types of commands map to a System Management Interrupt (SMI) that is issued to ACPI I/O port 0xB2.
Although WHEA commands are serialized by the operating system, they are not serialized in combination with PCC commands. Therefore, some of the WHEA commands are not run. This situation may cause the system to stop responding. When the system stops responding, a DPC watchdog time-out occurs and causes the Stop error message.

Resolution


To resolve this issue, we have released a hotfix for Windows 8, Windows Server 2012, Windows 7 or Windows Server 2008 R2. This hotfix is also available at Microsoft Update Catalog.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must install Service Pack 1 for Windows 7 or Windows Server 2008 R2.

Registry information

To enable this fix, you must create or modify the following registry subkey:

Registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WHEA\Policy
DWORD name: IgnoreDummyWrite
DWORD value: 1


Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.


Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References


See the terminology that Microsoft uses to describe software updates.