Event ID 55 is logged in Windows 7 or Windows Server 2008 R2 and Windows may crash

Applies to: Windows Server 2008 R2 EnterpriseWindows Server 2008 R2 DatacenterWindows Server 2008 R2 for Itanium-Based Systems More

Symptoms





When both of the following conditions are met, event ID 55 may be logged.
  • You have a file server that is running Windows 7 or Windows Server 2008 R2.
  • The cluster size (also known as the allocation unit size) for an NTFS volume is larger than 4 kilobytes (KB).

Specifically, the following event is logged in the System log: Additionally, because of file system corruption, the server may crash.

Cause


This issue occurs because the BITMAP attribute of the NTFS metafile cannot roll back when an exception is raised after you modify the metafile. When the system tries to extend the BITMAP attribute, there is no transaction in progress, and the attribute snapshots are purged before the system starts to process the exception. In this situation, file corruption may occur, and NTFS event ID 55 may be logged.

Resolution


To resolve this issue, we have released hotfixes for Windows 7 or Windows Server 2008 R2. Check out the prerequisites of the hotfix.

Note This hotfix does not fix the existing file system corruption. Therefore, you have to run the Chkdsk command together with the /f or /r parameter after you apply the hotfix.

For more information about the Chkdsk command, see Chkdsk.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Service Pack 1 installed in Windows 7 or Windows Server 2008 R2. 

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


Usually, event ID 55 is logged when file system corruption occurs. The file system corruption occurs when one or more of the following issues occur:
  • A disk has bad sectors.
  • I/O requests that are delivered by the file system to the disk subsystem are not completed successfully.
For the issue that is described in this article, event ID 55 is logged because the I/O requests are not completed successfully. When this issue happens, the bitmap information that manages file records proves to be inconsistent. Therefore, the user can’t find the file and folder properties. In this situation, the file index experiences an inconsistency, but in fact there is no file corruption. However, because of the logged event, it may seem like file corruption has occurred.

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates