GetOption or SetOptions method of IPrintCoreHelper interface does not update print device settings in Windows

Applies to: Windows Server 2008 R2 Service Pack 1Windows Server 2008 R2 DatacenterWindows Server 2008 R2 Enterprise More

Symptoms


Consider the following scenarios.

Scenario 1
  • You connect a print device that has an accessory output bin and certain trays to a computer that is running Windows 7, Windows Server 2008 R2, Windows RT, Windows 8, Windows Server 2012, Windows RT 8.1, Windows 8.1, or Windows Server 2012 R2.
  • The PCL6 or Postscript printer driver for the printer uses the GetOption or SetOption method of the IPrintCOreHelper interface to upgrade printer device settings. 
  • On the Device Settings tab in Printer properties, the trays and the accessory output bin are displayed correctly.
  • You remove the accessory output bin and some of the trays.
  • You upgrade the driver to a newer version.
In this scenario, the configurations on the Device Settings tab are not updated. Instead, the old configuration of four trays and an accessory output bin are displayed.

Scenario 2
  • You connect a print device that supports an accessory output bin and a duplex unit to a computer that is running Windows 7, Windows Server 2008 R2, Windows RT, Windows 8, Windows Server 2012, Windows RT 8.1, Windows 8.1, or Windows Server 2012 R2.
  • The PCL6 or Postscript printer driver for the printer uses the GetOption or SetOption method of the IPrintCOreHelper interface to upgrade printer device settings.
  • On the Device Settings tab in Printer properties, the duplex unit and the accessory output bin are displayed correctly.
  • You disconnect the print device, and then you connect the computer to another print device that does not support the accessory output bin or the duplex unit.
  • You upgrade the driver to a newer version.
In this scenario, the duplex unit and the accessory output bin are still displayed on the Device Settings tab.

Cause


This issue occurs because an API error during the upgrade prevents the driver from updating the user interface with the latest settings that are retrieved from the print device.

Resolution


Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2 SP1
  • Windows RT
  • Windows 8
  • Windows Server 2012
  • Windows RT 8.1
  • Windows 8.1
  • Windows Server 2012 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates