"HTTP 403" or "0x80040001" error when you connect to a DirectAccess server from a DCA tool in Windows 7 SP1

Applies to: Windows 7 EnterpriseWindows 7 Home BasicWindows 7 Home Premium More

Symptoms


Consider following scenario:

  • You have a DirectAccess Connectivity Assistant 2.0 tool installed on a computer that is running Windows 7 Service Pack 1 (SP1).
  • You use the tool to connect to the DirectAccess server by using One-Time Password Certificate Enrollment (OTPCE) protocol authentication through a HTTPS connection.
In this situation, you can encounter one of the following issues:

  • You receive a HTTP 403 error from the DirectAccess server as a response to the certificate-signing request.
  • You receive a 0x80040001 error after you enter the one-time password (OTP).

Cause


This issue occurs because of an error in the validation of the SSL certificate on the client-side computer that occurs before it uses OTPCE protocol authentication. Then, the cached certificate expires and is not refreshed to a valid certificate.

Resolution


To resolve this issue, install the hotfix that is described in this article.

Hotfix information


A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Prerequisites

To apply this hotfix, you must be running Windows 7 SP1.

For more information about how to obtain a Windows 7 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.


Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates.