You can't disable the NRPT in Windows 8 or Windows 8.1

Applies to: Windows 8 EnterpriseWindows 8.1 Enterprise

Symptoms


If the client is not connected to the DirectAccess server, you will not have the Disconnect option for disabling the Name Resolution Policy Table (NRPT) in Windows 8 or Windows 8.1.

Cause


By design, the Disconnect option to disable the NRPT is available only if you have already made a successful connection to the DirectAccess server.

Resolution


After you apply this hotfix, the Disconnect option to disable the NRPT is available when the DirectAccess client is not actually connected to a DirectAccess server. This gives users inside acorporate network access to corporate resources if the network location server becomes unavailable. It's a requirement that the network location server be highly available. However, if it becomes unavailable, the Windows 8.x clients that have this hotfix installed can use the Disconnect option to disable the NRPT in order to access corporate resources.

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 8 or Windows 8.1.

Additionally, you must first install update 2919355 on Windows 8.1.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References


Learn about the terminology that Microsoft uses to describe software updates.