Symptoms
Consider the following scenario:
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You enable an enhanced logging feature for Internet Information Services (IIS) 8.5 on a server in Windows 8.1 or Windows Server 2012 R2.
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The server's time zone settings are set to be later than Coordinated Universal Time (UTC) (such as UTC -04:00).
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You enable the Use Local Time for file naming and rollover setting in the IIS properties.
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You set log files to be rolled over on a schedule.
In this scenario, when the server receives HTTP requests within some time ranges, the W3C logging service tries to roll over, and then it crashes. Therefore, all loggings are disabled.
Cause
This issue occurs because the W3C logging service rolls over the log files incorrectly according to the UTC time instead of the local time.
Resolution
To resolve this issue, we have released an update rollup or hotfixes for Windows 8.1 or Windows Server 2012 R2.prerequisite of the hotfix.
Before you install this hotfix, check theThe update rollup fixes many other issues in addition to the issue that the hotfix fixes. We recommend that you use the update rollup. The update rollup is larger than the hotfix. Therefore, the update rollup takes longer to download.
Get the update rollup for Windows 8.1 or Windows Server 2012 R2To resolve this issue, install the update rollup that is dated December 2014. Get the December 2014 update rollup for Windows RT 8.1, Windows 8.1, or Windows Server 2012 R2
Get the hotfix for Windows 8.1 or Windows Server 2012 R2 A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.
If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
PrerequisitesTo apply this hotfix, you must first install update 2919355 in Windows 8.1 or Windows Server 2012 R2. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
2919355 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 Update April, 2014
Registry informationTo use the hotfix in this package, you do not have to make any changes to the registry.
Restart requirementYou may have to restart the computer after you apply this hotfix.
Hotfix replacement informationThis hotfix does not replace a previously released hotfix.
More Information
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates.
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 8.1 and Windows Server 2012 R2 file information and notesImportant Windows 8.1 hotfixes and Windows Server 2012 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8.1/Windows Server 2012 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
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The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information" section. MUM, MANIFEST, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 8.1
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
W3logsvc.dll |
8.5.9600.17225 |
66,560 |
02-Jul-2014 |
08:10 |
x86 |
For all supported x64-based versions of Windows 8.1 and of Windows Server 2012 R2
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
W3logsvc.dll |
8.5.9600.17225 |
76,800 |
02-Jul-2014 |
08:08 |
x64 |
W3logsvc.dll |
8.5.9600.17225 |
66,560 |
02-Jul-2014 |
08:10 |
x86 |
Additional file information
Additional file information for Windows 8.1 and for Windows Server 2012 R2
Additional files for all supported x86-based versions of Windows 8.1
File property |
Value |
---|---|
File name |
X86_317646b73127eb83cbf21b0175c0a4eb_31bf3856ad364e35_6.3.9600.17226_none_ac8a614eab3bd776.manifest |
File version |
Not applicable |
File size |
696 |
Date (UTC) |
04-Jul-2014 |
Time (UTC) |
00:15 |
Platform |
Not applicable |
File name |
X86_microsoft-windows-w3logsvc_31bf3856ad364e35_6.3.9600.17226_none_1990cf56f96bded0.manifest |
File version |
Not applicable |
File size |
4,466 |
Date (UTC) |
03-Jul-2014 |
Time (UTC) |
09:41 |
Platform |
Not applicable |
Additional files for all supported x64-based versions of Windows 8.1 and of Windows Server 2012 R2
File property |
Value |
---|---|
File name |
Amd64_9d24f7e66dca6163f6761b208950a130_31bf3856ad364e35_6.3.9600.17226_none_7927abdc987647d3.manifest |
File version |
Not applicable |
File size |
1,042 |
Date (UTC) |
04-Jul-2014 |
Time (UTC) |
00:18 |
Platform |
Not applicable |
File name |
Amd64_microsoft-windows-w3logsvc_31bf3856ad364e35_6.3.9600.17226_none_75af6adab1c95006.manifest |
File version |
Not applicable |
File size |
4,468 |
Date (UTC) |
03-Jul-2014 |
Time (UTC) |
10:52 |
Platform |
Not applicable |
File name |
Wow64_microsoft-windows-w3logsvc_31bf3856ad364e35_6.3.9600.17226_none_8004152ce62a1201.manifest |
File version |
Not applicable |
File size |
1,834 |
Date (UTC) |
03-Jul-2014 |
Time (UTC) |
09:41 |
Platform |
Not applicable |
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.