Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

When you try to set up Microsoft 365 Premium, you encounter an error that prevents you from completing the setup process. This error occurs only during the setup of the following installations:

  • Office Personal Premium with Microsoft 365 Services

  • Office Home and Business Premium with Microsoft 365 Services

  • Office Professional with Microsoft 365 Services

The error code that you receive ranges between 1000 and 1999.

Cause

This error is caused by an internal technical failure or an internal processing error in the online Office redemption service.

Resolution

If you experience this problem, it is probably caused by a temporary issue in our service that should be resolved shortly. In this situation, wait for a reasonable time period before you try to install and set up Office Premium again. For example, you may have to wait for as long as a day. If you continue to experience a 1000–1999 error after this waiting period, contact customer support.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Find solutions to common problems or get help from a support agent.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×