"Print to file" feature does not work through a Windows-based printer server that uses a version 4 printer driver

Applies to: Windows Server 2012 R2 DatacenterWindows Server 2012 R2 StandardWindows Server 2012 R2 Essentials

This article describes an issue that occurs when a printer server is running Windows 8.1, Windows RT 8.1, or Windows Server 2012 R2. A hotfix is available to resolve this issue. The hotfix has a prerequisite.

Symptoms


This issue occurs if the Point and Print feature is enabled on the printer server. When you select the Print to file check box in the Print dialog box to print through an application, a zero-byte file is created and you receive an error message. The following list indicates the application that is used and the corresponding error message that you may receive:
  • Notepad:

    The handle is invalid.
  • WordPad:

    Could not start print job.
  • Microsoft Word 2013:

    Windows cannot print due to a problem with the current printer setup.
Note This issue does not occur if the printer server uses a version 3 printer driver.

Cause


This issue occurs because the version 4 printer drivers do not support the print to file feature.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Prerequisites

To apply this hotfix, you must have update 2919355 installed in Windows 8.1 or Windows Server 2012 R2.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References


See the terminology that Microsoft uses to describe software updates.