RDP session becomes unresponsive when you connect to a Windows Server 2012 R2-based computer

Se aplica a: Windows Server 2012 R2 DatacenterWindows Server 2012 R2 StandardWindows Server 2012 R2 Essentials Más

This article describes an issue that occurs when you create a Remote Desktop Protocol (RDP) session to connect to a computer that is running Windows Server 2012 R2. A hotfix is available to resolve this issue. The hotfix has a prerequisite and a restart requirement.

Symptoms


When this issue occurs, you cannot log back into the Remote Desktop Services (RDS) farm. Additionally, you have to hard restart the server to recover.

Resolution


To resolve this issue, we have released a hotfix. Even though this issue has only been observed in Windows Server 2012 R2, the hotfix also applies to Windows 8.1.

Hotfix information

Important Do not install a language pack after you install this hotfix. If you do, the language-specific changes in the hotfix will not be applied, and you will have to reinstall the hotfix. For more information, see Add language packs to Windows.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Prerequisites

To apply this hotfix, you must have April 2014 update rollup for Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 (2919355) installed in Windows 8.1 or Windows Server 2012 R2.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


Cause

This issue occurs because there is an infinite loop in a function.

References


See the terminology that Microsoft uses to describe software updates.