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This article describes an issue in which snapshots are not deleted after you perform a backup operation by using Volume Shadow Copy Service (VSS) in Windows Server 2012 R2. A hotfix is available to resolve this issue. Before you install this hotfix, check out the Prerequisites section.

Symptoms

When you use a backup application that uses VSS to back up files, you might notice an unexpected increase in disk space usage. This may occur in a corner case. When you examine the disk, you find that it is filled with undeleted snapshot files.

Note You can use the vssadmin list shadows command to determine whether the problem is caused by undeleted snapshot files.

Cause

This issue occurs because VSS encounters a race condition that prevents the snapshot deletion feature from deleting all snapshots.

Resolution

Hotfix information

Important Do not install a language pack after you install this hotfix. If you do, the language-specific changes in the hotfix will not be applied, and you will have to reinstall the hotfix. For more information, see Add language packs to Windows.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have update 2919355 installed in Windows 8.1 or Windows Server 2012 R2.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 8.1 and Windows Server 2012 R2 file information and notes

Important Windows 8.1 hotfixes and Windows Server 2012 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8.1/Windows Server 2012 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.3.960 0.17 xxx

    Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2

    RTM

    GDR

  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information" section. MUM, MANIFEST, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows 8.1

File name

File version

File size

Date

Time

Platform

Volsnap.sys

6.3.9600.17824

265,048

07-May-2015

16:48

x86

For all supported x64-based versions of Windows 8.1 and of Windows Server 2012 R2

File name

File version

File size

Date

Time

Platform

Volsnap.sys

6.3.9600.17824

316,760

07-May-2015

17:44

x64

For all supported Windows RT 8.1

File name

File version

File size

Date

Time

Platform

Volsnap.sys

6.3.9600.17824

244,584

07-May-2015

16:29

Not applicable

Additional file information

Additional file information for Windows 8.1 and for Windows Server 2012 R2

Additional files for all supported x86-based versions of Windows 8.1

File property

Value

File name

X86_volume.inf_31bf3856ad364e35_6.3.9600.17824_none_aa974e46177df3c9.manifest

File version

Not applicable

File size

2,100

Date (UTC)

07-May-2015

Time (UTC)

16:55

Platform

Not applicable

Additional files for all supported x64-based versions of Windows 8.1 and of Windows Server 2012 R2

File property

Value

File name

Amd64_volume.inf_31bf3856ad364e35_6.3.9600.17824_none_06b5e9c9cfdb64ff.manifest

File version

Not applicable

File size

2,104

Date (UTC)

07-May-2015

Time (UTC)

17:48

Platform

Not applicable

Additional files for all supported Windows RT 8.1

File property

Value

File name

Arm_volume.inf_31bf3856ad364e35_6.3.9600.17824_none_aa99c09e177b128f.manifest

File version

Not applicable

File size

2,100

Date (UTC)

07-May-2015

Time (UTC)

16:34

Platform

Not applicable



Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

See the terminology that Microsoft uses to describe software updates.

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