Symptoms
In an Exchange Server 2013 environment, POP3 and IMAP4 users can't access their mailboxes if Managed Availability responders try to run the RestartService action. The responders fail because of invalid WindowsService names. In this situation, you may find the info logged in the RecoveryActionResults log:
Id: RestartService
InstanceId: 150813.060155.26112.001 ResourceName: POP.Protocol StartTime: datetime.2611275Z EndTime: datetime.2767647Z State: Finished Result: Failed RequestorName: PopDeepTestRestartService ExceptionName: InvalidOperationException ExceptionMessage: Service POP.Protocol was not found on computer '.'.
Id: RestartService
InstanceId: 150813.060655.30081.001 ResourceName: IMAP StartTime: datetime.3008143Z EndTime: datetime.3008143Z State: Finished Result: Failed RequestorName: ImapCTPRestartService ExceptionName: InvalidOperationException ExceptionMessage: Service IMAP was not found on computer '.'.
Cause
This issue occurs because an invalid ServiceName value is passed in the Restart Service responder implementation.
Resolution
To fix this issue, install Cumulative Update 12 for Exchange Server 2013 or a later cumulative update for Exchange Server 2013.
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
References
Learn about the terminology that Microsoft uses to describe software updates.