Symptoms

In a Microsoft Exchange Server 2013 environment, you try to use eDiscovery through the Exchange Administration Center (EAC) to search all mailboxes or some distribution groups. If you have the "Search All Mailboxes" check box selected, the search fails and the following exception is generated:

InfoWorker.Common Search MailboxSearchServer.Start error System.ArgumentNullException: Value cannot be null. ----- ----- Parameter name: id ----- ----- at Microsoft.Exchange.EDiscovery.MailboxSearch.SourceMailbox..ctor(String id String name String legacyDN Uri serviceEndpoint String queryFilter) ----- ----- at Microsoft.Exchange.EDiscovery.MailboxSearch.MailboxSearchConfigurationProvider.ValidateAndAddToFinalSourceMailboxes(String searchQuery StorageMiniRecipient recipient IList`1 finalSourceMailboxes IList`1 versionSkippedMailboxes IList`1 rbacDeniedMailboxes Dictionary`2 crossPremiseMailboxes) ----- ----- at Microsoft.Exchange.EDiscovery.MailboxSearch.MailboxSearchConfigurationProvider.ValidateAndGetFinalSourceMailboxes(String searchQuery IList`1 sourceMailboxes IList`1 notFoundMailboxes IList`1 versionSkippedMailboxes IList`1 rbacDeniedMailboxes IList`1 crossPremiseFailedMailboxes IDictionary`2 crossPremiseUrls) ----- ----- at Microsoft.Exchange.EDiscovery.MailboxSearch.MailboxSearchWorkItem.PreStart(String executingUserId IMailboxSearchTask searchTask) ----- ----- at Microsoft.Exchange.EDiscovery.MailboxSearch.MailboxSearchServer.AddSearchToWorkItemQueue(SearchId searchId String ownerId)"

Cause

This problem occurs when the Mailcontact or Mailuser objects are contained in the search query.

Resolution

To fix this problem, install Cumulative Update 12 for Exchange Server 2013 or a later cumulative update for Exchange Server 2013.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

Learn about the terminology that Microsoft uses to describe software updates.

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