The Microsoft .NET Framework 4.7 for Windows 8.1, Windows RT 8.1, and Windows Server 2012 R2

Applies to: Windows 8.1 EnterpriseWindows RT 8.1Windows Server 2012 R2 Standard

This article describes an update for the Microsoft .NET Framework 4.7 for Windows 8.1, Windows RT 8.1, and Windows Server 2012 R2.

About the .NET Framework 4.7


The .NET Framework 4.7 is a highly compatible and in-place update to the .NET Framework 4.5.1, 4.5.2, 4.6, 4.6.1, and 4.6.2. However, it can run side-by-side with the .NET Framework 3.5 Service Pack 1 (SP1) and earlier versions of the .NET Framework.

When you install this package, you can see it installed as Update for Microsoft Windows (KB3186539) under the Installed Updates item in Control Panel.

Note A recommended update may be installed automatically on all supported platforms, based on your computer settings on Windows Update.

Download Information


The following file is available for download from the Microsoft Download Center:

Download Download the Microsoft .NET Framework 4.7 offline installer package now.

For more information about the .NET Framework 4.7 offline installer, see The .NET Framework 4.7 offline installer for Windows.

For more information about how to download Microsoft support files, see How to obtain Microsoft support files from online services.

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Known issues


For known issues in the .NET Framework 4.7 and Microsoft Exchange Server, see .NET Framework 4.7 and Exchange Server.

For other known issues in the .NET Framework 4.7, see the .NET Framework 4.7 known issues.

More Information


Command-line switches for this update

For more information about the various command-line options that are supported by this update, see the "Command-Line options" section in the .NET Framework Deployment Guide for Developers on the MSDN website.

Restart requirement

You may have to restart the computer after you install this update. We recommend that you close all applications that are using the .NET Framework before you install this update.

Applies to

Microsoft .NET Framework 4.7, Windows 8.1, Windows RT 8.1, and Windows Server 2012 R2