Microsoft .NET Framework 4.7.2 Language Pack (Offline Installer) for Windows

Applies to: Windows Server 2016Windows Server 2012 R2Windows Server 2012 More

Introduction


This article describes Microsoft .NET Framework 4.7.2 Language Pack. You must have the English version of .NET Framework 4.7.2 installed on your computer before you install a language pack. Download and install .NET Framework 4.7.2 from the Microsoft Download Center:

Microsoft .NET Framework 4.7.2 (Offline Installer)

About Microsoft .NET Framework 4.7.2 Language Pack


Microsoft .NET Framework 4.7.2 Language Pack contains translated error messages and other UI text for languages other than English. If you do not install a language pack, this text is displayed in English. You can install multiple language packs on one computer, each for a different language.

Download information


The following table contains download links for individual language packs for the 23 supported languages.

.NET Framework 4.7.2 Language Pack

Arabic (ar-SA)

Chinese-China (zh-CN)

Chinese-Taiwan (zh-TW)

Czech (cs-CZ)

Danish (da-DK)

German (de-DE)

Greek (el-GR)

Spanish (es-ES)

Finnish (fi-FI)

French (fr-FR)

Hebrew (he-IL)

Hungarian (hu-HU)

Italian (it-IT)

Japanese (ja-JP)

Korean (ko-KR)

Dutch (nl-NL)

Norwegian (nb- NO)

Polish (pl-PL)

Portuguese - Brazil (pt-BR)

Portuguese - Portugal (pt- PT)

Russian (ru-RU)

Swedish (sv-SE)

Turkish (tr-TR)


For information about how to download Microsoft support files, see How to obtain Microsoft support files from online services.

More information


This version of .NET Framework Language Pack installs side-by-side with .NET Framework 3.5 Service Pack 1 Language Pack and earlier versions but performs an in-place update for .NET Framework 4, 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, and 4.71 language packs.

Known issues

  • Applications that rely on .NET Framework to initialize a COM component and that run with restricted permissions may fail to start or run correctly, and return "access denied," "class not registered," or "internal failure occurred for unknown reasons" errors.
  • For the known issues in .NET Framework 4.7.2, see .NET Framework 4.7.2 Known Issues.

Command-line switches for this update

For more information about the various command-line options that are supported by this update, see .NET Framework Deployment Guide for Developers.

Restart requirement

You may have to restart the computer after you install this update. We recommend that you close all applications that are using .NET Framework before you install this update.

Supported operating systems

Microsoft .NET Framework 4.7.2 Language Pack (Offline Installer) supports the following operating systems:

  • Windows 7 Service Pack 1 (x86 and x64)
  • Windows 8.1 (x86 and x64)
  • Windows 10 Anniversary Update (version 1607) (x86 and x64)
  • Windows 10 Creators Update (version 1703) (x86 and x64)
  • Windows 10 Fall Creators Update (version 1709) (x86 and x64)
  • Windows Server 2008 R2 Service Pack 1 (x64)
  • Windows Server 2012 (x64)
  • Windows Server 2012 R2 (x64)
  • Windows Server 2016 (x64)