Security Only updates for .NET Framework 3.5 SP1, 4.5.2, and 4.6 for Windows Server 2008 SP2 (KB 4471984)

Applies to: .NET Framework

Summary


This security update resolves a vulnerability in Microsoft .NET Framework that could allow remote code execution when Microsoft .NET Framework doesn't validate input correctly. An attacker who successfully exploits this vulnerability could take control of an affected system. The attacker could then install programs; view, change, or delete data; or create new accounts that use full user rights. Users whose accounts are configured to have fewer user rights on the system could be less affected than users who are granted administrative user rights.

To exploit the vulnerability, an attacker has to pass specific input to an application that uses susceptible .NET Framework methods.

This security update addresses the vulnerability by correcting how .NET Framework validates input.

To learn more about this vulnerability, see Microsoft Common Vulnerabilities and Exposures CVE-2018-8540.

Important

  • All updates for .NET Framework 4.6 for Windows Server 2008 Service Pack 2 (SP2) require that the d3dcompiler_47.dll update is installed. We recommend that you install the included d3dcompiler_47.dll update before you apply this update. For more information about the d3dcompiler_47.dll update, see KB 4019478.
  • If you install a language pack after you install this update, you must reinstall this update. Therefore, we recommend that you install any language packs that you need before you install this update. For more information, see Add language packs to Windows.

Additional information about this security update


The following articles contain additional information about this security update as it relates to individual product versions.
 
  • 4470633 Description of the Security Only update for .NET Framework 3.5 SP1 for Windows Server 2008 SP2 (KB 4470633)
  • 4470493 Description of the Security Only update for .NET Framework 4.5.2 for Windows 7 SP1, Server 2008 R2 SP1, and Server 2008 SP2 (KB 4470493)
  • 4470500 Description of the Security Only update for .NET Framework 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1, and 4.7.2 and for .NET Framework 4.6 for Windows Server 2008 SP2 (KB 4470500)

How to obtain help and support for this security update