PSTN call transfer fails if agent anonymity is enabled in Skype for Business Server 2015

Applies to: Skype for Business Server 2015

Symptoms


When agent anonymity is enabled on the workflow in a response group in Microsoft Skype for Business Server 2015, the agent is unable to transfer an incoming PSTN call to another PSTN user.

Cause


This issue occurs because the transfer request to PSTN gateway doesn't have any telephone number in the DID range. Thus PSTN carrier blocks the outgoing call.

Resolution


To fix this issue, install the May 2020 cumulative update 6.0.9319.580 for Skype for Business Server 2015, Response Group Service.