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Symptoms

After you install or upgrade to Microsoft Exchange Server 2019 Cumulative Update (CU) 8, you receive error messages that resemble the following in computers event log:

Log Name:      Application
Source:        ASP.NET 4.0.30319.0
Event ID:      1309
Task Category: Web Event
Level:         Warning
Keywords:      Classic
Description:

Exception information: 
Exception type: DuplicateKeyException 
Exception message: Cannot add a duplicate key. Use Insert instead
at Microsoft.Exchange.Security.Authentication.FederatedAuthService.CacheReader.AddEntry(String userKey, Int32 userPolicy, ConfigWrapper config)

or

Log Name:      Application
Source:        MSExchange Common
Event ID:      4999
Task Category: General
Level:         Error
Keywords:      Classic
Description:

Watson report about to be sent for process id: 3292, with parameters: E12IIS, c-RTL-AMD64, 15.02.0659.004, w3wp#MSExchangePowerShellFrontEndAppPool, M.Exchange.Security, M.E.S.A.F.CacheReader.AddEntry, M.E.C.TimeoutCache.DuplicateKeyException, 28e2-dumptidset, 15.02.0659.004.
ErrorReportingEnabled: True

or

Log Name:      Application
Source:        MSExchange Front End HTTP
Event ID:      1003
Task Category: Core
Level:         Error
Keywords:      Classic
Description:

[PowerShell] An internal server error occurred. The unhandled exception was: Microsoft.Exchange.Collections.TimeoutCache.DuplicateKeyException: Cannot add a duplicate key. Use Insert instead
   at Microsoft.Exchange.Security.Authentication.FederatedAuthService.CacheReader.AddEntry(String userKey, Int32 userPolicy, ConfigWrapper config)
   at Microsoft.Exchange.Security.Authentication.FederatedAuthService.BasicAuthPolicyRepo.GetUserPolicy(String userKey, Int32 traceId, Int32& userPolicy, HttpApplication httpApplication, IRecipientSession recipientSession, IConfigurationSession configSession, ConfigWrapper config)
   at Microsoft.Exchange.Security.Authentication.FederatedAuthService.BasicAuthPolicyEvaluator.IsBasicAuthAllowed(String userKey, String protocolName, Int32 traceId, HttpApplication httpApplication, IRecipientSession recipientSession, IConfigurationSession configSession, ConfigWrapper config)
   at Microsoft.Exchange.HttpProxy.ProxyModule.IsLegacyAuthAllowed(HttpApplication httpApplication)
   at Microsoft.Exchange.HttpProxy.ProxyModule.OnPostAuthenticateInternal(HttpApplication httpApplication)
   at Microsoft.Exchange.Common.IL.ILUtil.DoTryFilterCatch(Action tryDelegate, Func`2 filterDelegate, Action`1 catchDelegate)

Cause

This issue is caused by an internal change applied in Exchange Server 2019 CU8. You can safely ignore these event log entries now. The behavior will be addressed with a later update.

Resolution

To fix this issue, install the Cumulative Update 9 for Exchange Server 2019 or a later cumulative update for Exchange Server 2019.

Workaround

Users could be prompted for credentials for Outlook when receiving the DuplicateKeyException error that's described in the Symptoms section. You can run the following command to revert the change that was made in CU8:

Set-OrganizationConfig -DefaultAuthenticationPolicy $null

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