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Symptoms

When you start Business Portal, you may be prompted for a username and a password. This problem occurs in the following products:

  • Business Portal in Microsoft Dynamics GP

  • Business Portal in Microsoft Business Solutions - Great Plains

  • Business Portal in Microsoft Dynamics SL

  • Business Portal in Microsoft Business Solutions - Solomon

Cause

Cause 1

This problem may be caused by the configuration setting in Microsoft Internet Information Services (IIS). See Resolution 1 in the "Resolution" section.

Cause 2

This problem may be caused by the configuration settings in Microsoft Internet Explorer. See Resolution 2 in the "Resolution" section.

Cause 3

This problem may occur because the Windows SharePoint roles and the Business Portal roles are not synchronized correctly. See Resolution 3 in the "Resolution" section.

Cause 4

This problem may occur if the users have been removed and re-added in the Active Directory directory service by using the same user name, the Security ID (SID) for the user may be different in Active Directory from what is listed in Windows SharePoint Services (WSS). See Resolution 4 in the "Resolution" section.

Cause 5

This problem may occur because there is a corrupted Ntuser.dat file for the specific user who is experiencing the problem. See Resolution 5 in the "Resolution" section.

Cause 6

This problem may occur because a company logo has been added to the pages in Business Portal, and the user may not have the NTFS file system permissions to the file that contains the logo. See Resolution 6 in the "Resolution" section.

Cause 7

This problem may occur if a user does not have the correct rights to the physical ASP.NET *.aspx files. See Resolution 7 in the "Resolution" section.

Cause 8

This problem may occur if your SharePoint Web Application uses Kerberos authentication. See Resolution 8 in the "Resolution" section.

Resolution

Resolution 1

To verify the configuration setting in IIS, follow these steps:

  1. Log on to the server that is running IIS as a user who has local administrative permissions.

  2. Click Start, click Run, type inetmgr, and then click OK.

  3. Right-click the Web site on which Business Portal is installed, and then click Properties.

  4. Click the Directory Security tab.

  5. In the Authentication and Access Control window, click Edit.

  6. Click to select the Integrated Windows Authentication check box, and then click OK.

    Note The Integrated Windows Authentication check box should be the only check box that is selected in this window. If Basic Authentication is enabled in IIS, you are prompted to log on every time that the Web site is accessed in that Internet Explorer session. If Digest Authentication is enabled, you are also prompted to log on every time that the Web site is accessed. But Digest Authentication requires Active Directory, and the username and the password are encrypted.

  7. Expand the Web site on which Business Portal is installed, right-click the BusinessPortal virtual directory, click Properties, and then repeat steps 5 through 7 earlier in this section.

Resolution 2

To verify the configuration settings in Internet Explorer, follow these steps:

  1. In Internet Explorer, determine whether Business Portal uses the Local Intranet zone or the Trusted Sites zone. To do this, start Business Portal, and then note which zone is listed in the lower-right corner of the Internet Explorer window for the Business Portal site.

  2. Click Tools, click Internet Options, and then click the Security tab.

  3. Depending on which zone Business Portal uses, click either Local Intranet or Trusted Sites, and then click Custom Level.

    Note Refer to step 1 earlier in this section to determine which zone Business Portal uses.

  4. Make sure that all ActiveX options are set to Enabled.

  5. In the User Authentication section, make sure that the Automatic Logon with current username and password check box is selected.

  6. To clear any incorrect passwords from the cache, use the appropriate step:

    • If you are using Windows Internet Explorer 7, click the General tab, click Delete, and then click Delete passwords.

    • If you are using Windows Internet Explorer 6, click the Content tab, click AutoComplete, and then click Clear Passwords.

  7. Verify that the Discuss option is not enabled in Internet Explorer. To do this, click View, click Explorer Bar, and then click to remove the check mark next to Discuss.

Note The Internet Explorer settings must be configured on each workstation for each user who is experiencing the problem.

Resolution 3

To resolve this problem, run Role Synchronization in Business Portal. To do this, follow these steps:

  1. Start Business Portal as a user who is assigned the Administrator Role in Business Portal for All companies.

  2. Click Site Settings, click Users and Permissions, click Manage Roles, and then click Check role synchronization.

  3. Click All, and then click Check.

  4. If errors are reported, click Update.

Note This feature does not exist in Business Portal in Microsoft Dynamics GP 10.0, or in Business Portal in Microsoft Dynamics SL 7.0.

Resolution 4

To resolve this problem, run the ValidateBPUser utility to locate the user or users who have invalid SIDs. To do this, follow these steps:

  1. Download the ValidateBPUser.exe utility. To download the ValidateBPUser.exe utility, visit the following Microsoft Web site:

    https://mbs.microsoft.com/fileexchange/?fileID=8069b581-a52b-4705-90c7-0ed728fe0b9eNote Download the utility to the computer that is running Business Portal.

  2. Modify the following two parameters in the ValidateBPusers.exe.config file, based on the specific environment:

    1. WebServerRootUrl
      This is the URL that is hosting Business Portal. For example, if you installed Business Portal to the Default Web site, the URL is http://IISComputerName.

    2. BusinessPortalBPSharePointRootSiteUrl
      This is the Business Portal SharePoint Site Root URL. It is equivalent to the wssObjectModelSiteURL parameter in the BusinessFramework.config file.

  3. Run the ValidateBPUser.exe utility. To do this follow these steps

    Note Make sure that you run the utility as a Business Portal user who is assigned the BP Administrator (All companies) role. If the user is not assigned to the BP Administrator role, the user is prompted for a username and a password.

    1. In an MS-DOS window, move to the directory in which you saved the utility, and then type the following command at the command prompt:

      validateBPUsers.exe verbose

    2. Type exit to close the window.

  4. The utility updates the BusinessPortalSharepointSIDMismatches.xml file. The file contains all the users whose SID in Active Directory does not correspond to the SID in WSS. By default, this file is located in the following folder:

    C:\Program Files\Common Files\Microsoft Shared\web server extensions\60\BIN

  5. If the file contains users who have unmatching SIDs, contact Technical Support for Microsoft Dynamics.

Resolution 5

To resolve the corrupted Ntuser.dat file, re-create the user profile.For more information about how to re-create the user profile, click the following article number to view the article in the Microsoft Knowledge Base:

811151 How to copy data from a corrupted user profile to a new profile

Resolution 6

To resolve this problem, give the user Full Control NTSF permissions to the file that contains the logo. To do this, follow these steps:

  1. Locate the file that contains the logo. To do this, click Site Settings, click General Settings, and then click Change Portal Logo.

  2. Right-click the file, and then click Properties.

  3. On the Security tab, click Add.

  4. In the Enter the object names to select area, type the name of the user who is being prompted, click Check Names, and then click OK.

  5. In the Permissions area, click Allow for the Full Control option, and then click OK.

Resolution 7

To resolve this problem, give explicate rights to all the physical files that are used by the Web site. Or, as a test to see whether the error still occurs, make the user a local administrator on the Business Portal computer.

Resolution 8

To resolve this problem, enable NTLM authentication for your Business Portal Web Application. To do this, follow these steps for the appropriate version below:


Sharepoint 3.0

  1. On the Business Portal server click Start, click Control Panel, click Administrative Tools, and then click SharePoint 3.0 Central Administration.

  2. Click the Application Management tab.

  3. Under Application Security, click Authentication providers.

  4. Make sure that your Business Portal Web application is selected in the upper-right corner.

  5. Click Default.

  6. Under IIS Authentication Settings, make sure that the Integrated Windows authentication check box is selected. Also make sure that NTLM is selected.

  7. Click Save.

  8. Restart IIS.

  9. Start Business Portal, and check whether the problem still occurs.

Sharepoint 2010

  1. On the Business Portal server click Start, click All Programs, click SharePoint 2010 Products, and then click SharePoint 2010 Central Administration.

  2. Click Manage Web Applications.

  3. Click to highlight the site that your Business Portal Web application is installed on.

  4. In the Security section click Authentication Providers, and then click Default.

  5. In the IIS Authentication Settings section, make sure that the Integrated Windows authentication check box is selected. Also make sure that NTLM is selected.

  6. Click Save.

  7. Restart IIS.

  8. Start Business Portal, and check whether the problem still occurs.

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