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Symptoms

If you run Microsoft Dynamics GP 10.0 in a Citrix environment, the copy (CTRL+C) and paste (CTRL+V) functionality does not work in Microsoft Dynamics GP. You can no longer copy or paste between a local application and a session or between different applications in a session.

Cause

This behavior occurs because the Microsoft Dynamics GP application incorrectly inserts itself in the Windows clipboard chain on a local workstation or within the session.

Resolution

To resolve this problem, obtain the latest service pack for Microsoft Dynamics GP 10.0. For more information, visit one of the following Microsoft Web sites, depending on whether you are a partner or a customer.

Partners

https://mbs.microsoft.com/partnersource/downloads/servicepack/Customers

https://mbs.microsoft.com/customersource/support/downloads/servicepacks

Workaround

To work around this behavior, temporarily repair the clipboard chain by using the RepairCBDChain tool:

  1. Download the RepairCBDChain tool. To download the RepairCBDChain tool, visit the following Web site:

    http://support.citrix.com/article/CTX106226

  2. Verify that Microsoft Dynamics GP 10.0 is running.

  3. At a command prompt, change the directory to where the RepairCBDChain tool is located.

  4. Type RepairCBDChain.exe, and then press ENTER.


    Note Every time that you run Microsoft Dynamics GP, you have to complete these steps so that the copy and paste functionality will work.

If Microsoft Dynamics GP is deployed as a published application where the user does not have access to the desktop, follow these steps:

  1. Make a backup copy of the Dynamics.set file.

  2. Make a backup copy of the Dex.ini file.

  3. Copy the Launcher.cnk file from the \Tools\Continuum folder in Microsoft Dynamics GP 10.0 CD VOL 2 to the Microsoft Dynamics GP 10.0 installation directory. The Microsoft Dynamics GP 10.0 installation directory may be as follows:

    C:\Program Files\Microsoft Dynamics\GP\

  4. Copy the RepairCBDChain.exe file to the root drive (for example, C:\RepairCBDChain.exe).

  5. Open the Dex.ini file that is located in the Microsoft Dynamics GP 10.0 installation directory by using Notepad. The Microsoft Dynamics GP 10.0 installation directory may be as follows:

    C:\Program Files\Microsoft Dynamics\GP\Data\

  6. Add the following line to the bottom of the Dex.ini file:

    OLE_Application1=C:\RepairCBDChain.exeNotes

    • Change the path to the path where you copied the RepairCBDChain.exe file in step 4. The path cannot contain a folder whose name uses spaces or special characters.

    • Replace 1 with 2 if you already have an OLE_Application1 line in the Dex.ini file from other add-in Continuum applications. If you already have some OLE_ApplicationX lines, replace 1 with X+1.

  7. Save and close the Dex.ini file.

  8. Start Microsoft Dynamics GP 10.0, and then click Yes to include new code if you are prompted.


    Note The Dynamics.set file will have PRODID "851" with the name "Continuum Application Launcher" added to it.

  9. Log on to a company in Microsoft Dynamics GP, and then verify that the copy and paste functionality works.

To safely remove this workaround, revert to the original Dex.ini and Dynamics.set files.

More Information

When you have installed the Launcher tool and start Microsoft Dynamics GP, you may receive a message that the RepairCBDChain tool is running. You can click through this message window. If you do not want to receive this message, refer to parameters that are described in Citrix Document ID CTX106226. To access this document, visit the following Citrix Web site:

http://support.citrix.com/article/CTX106226ImportantMake sure that you do not remove the OLE_Application1 line from the Dex.ini file or delete the RepairCBDChain.exe file. If you remove the OLE_Application1 line or you delete the RepairCBDChain.exe file unexpectedly, the copy and paste functionality will be broken. Additionally, you may receive an out of memory type error message or a dexterity type error message when you start Microsoft Dynamics GP.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Dynamics GP 10.0 Service Pack 3.

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