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Symptoms

Consider the following scenario:

  • You have Microsoft Commerce Server 2007 or Microsoft Commerce Server 2009 installed on a computer. The computer is configured to use a symbol other than a period (.) for the decimal separator. For example, the computer is configured to use a comma (,) for the decimal separator.

    Note On a Windows-based computer, you can change the decimal separator setting in the Regional and Language Options item of
    Control Panel.

  • You specify a Decimal type in the Assigned Variant Property box of a product definition.

  • In Catalog Manager, you try to edit the variant property value for a product that is based on the product definition.

In this scenario, the variant property value is saved incorrectly. Specifically, the decimal separator is removed when the variant property value is saved.

For example, you use a comma (,) for the separator. Then, if you specify 1,5 as the value of the variant property, the value is saved as 15.

Cause

The issue occurs because the Catalog Manager always uses "en-us" as the locale when Catalog Manager saves variant property values. Because the "en-us" locale uses a period (.) for the decimal separator, other symbols are removed when the value is saved.

Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Commerce Server 2007 Service Pack 2 (SP2) or Commerce Server 2009 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Commerce Server 2007

File name

File version

File size

Date

Time

Platform

Catalogmanager.exe

6.0.4109.18

1,906,528

23-Apr-2009

11:33

x86

Commerce Server 2009

File name

File version

File size

Date

Time

Platform

Catalogmanager.exe

6.0.4171.2

1,769,472

14-May-2009

16:56

x86


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

In Commerce Server, you can use the Commerce Server Catalog and Inventory Schema Manager to manage the database schema for Catalog System. For more information about Catalog and Inventory Schema Manager, visit the following Microsoft Web site:

http://msdn.microsoft.com/en-us/library/ms962252.aspxFor more information about Managing Catalog and Inventory Schema, visit the following Microsoft Web site:

http://msdn.microsoft.com/en-us/library/ms915810.aspx

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