You are currently offline, waiting for your internet to reconnect

The body of an email message is empty when you try to use an IMAP client application to read it in an Exchange Server 2010 environment

SYMPTOMS
You try to use an Internet Message Access Protocol (IMAP) client application to read an email message in a Microsoft Exchange Server 2010 environment. However, the body of the email message is empty. This issue occurs when the content type of the MIME message of the email message is multipart and the multipart only has a single subpart.

For example, the following MIME message cannot be read by using the IMAP application:
Content-Type: multipart/mixed;                        boundary="-1970672470-1383129417-1288825231=:5310"Subject: testMIME-Version: 1.0 ---1970672470-1383129417-1288825231=:5310Content-Type: text/plain; charset="ISO-8859-1"; format=flowedContent-Transfer-Encoding: 8BIT Some text here ---1970672470-1383129417-1288825231=:5310--

CAUSE
This issue occurs because the Microsoft Exchange IMAP4 service incorrectly responds to the IMAP FETCH (BODYSTRUCTURE) command.
RESOLUTION
To resolve this issue, install the following update rollup:
2529939 Description of Update Rollup 3 for Exchange Server 2010 Service Pack 1
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
MORE INFORMATION
For more information about the multipart content type, visit the following Microsoft website:
Properties

Article ID: 2487501 - Last Review: 04/06/2011 18:44:00 - Revision: 3.0

Microsoft Exchange Server 2010 Service Pack 1

  • kbqfe kbfix kbhotfixrollup kbexpertiseinter kbsurveynew KB2487501
Feedback
">dqp0';m.content='true';document.getElementsByTagName('head')[0].appendChild(m);" onload="var m=document.createElement('meta');m.name='ms.dqp0';m.content='false';document.getElementsByTagName('head')[0].appendChild(m);" src="http://c1.microsoft.com/c.gif?"> >/html>did=1&t=">