You are currently offline, waiting for your internet to reconnect

"80040154" error message when you try to configure external Client Access namespaces on an Exchange Server 2010 server

SYMPTOMS
Consider the following scenario:

  • You have a computer that is running Microsoft Exchange Server 2010 in a mixed Exchange Server 2010 Service Pack 1 (SP1) and Exchange Server 2007 environment.
  • You have another computer that is running Exchange Server 2007 in this environment. This server has Windows Server 2003 and IIS 6.0 installed.
  • You configure external Client Access namespaces on the Exchange Server 2010 server.
In this scenario, the operation fails. Additionally, you receive the following error message:

Retrieving the COM class factory for remote component with CLSID {<xxxxx>} from machine <server name> failed due to the following error: 80040154.

Note
This issue also occurs when you run the Get-ActivesyncVirtualDirectory cmdlet without specifying the Windows Server 2003-based Exchange Server 2007 server.
CAUSE
This issue occurs because the version of Exchange Server 2010 is returned in the scenario that is described in the "Symptoms" section. However, the version of Exchange Server 2007 should be returned instead.
RESOLUTION
To resolve this issue, install the following update rollup:
2579150 Description of Update Rollup 4 for Exchange Server 2010 Service Pack 1
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
MORE INFORMATION
For more information about how to configure external Client Access namespaces, visit the following Microsoft website:For more information about the Get-ActivesyncVirtualDirectory cmdlet, visit the following Microsoft website:
Properties

Article ID: 2537099 - Last Review: 07/28/2011 02:36:00 - Revision: 3.0

  • Microsoft Exchange Server 2010 Service Pack 1
  • kbqfe kbfix kbsurveynew kbexpertiseinter kbhotfixrollup KB2537099
Feedback