You are currently offline, waiting for your internet to reconnect

Your browser is out-of-date

You need to update your browser to use the site.

Update to the latest version of Internet Explorer

Address Book service crashes on an Exchange Server 2010 Client Access server when a server has been running for 25 days or more

Symptoms
Assume that a Microsoft Exchange Server 2010 Client Access server role is installed on a server. When the server has been running for 25 days or more, the Address Book service crashes. Additionally, the following event is logged in the Application log:

Time: Time 
ID: 4999
Message: Watson report about to be sent for process id: Process ID, with parameters: E12, Build Type, Version Number, M.E.AddressBook.Service, M.E.Data.Storage, M.E.D.S.A.SimpleMiniClientAccessServerOrArrayLookup.FindServerIdWithClientAccess, System.ArgumentOutOfRangeException, XXXX, Version Number
ErrorReportingEnabled: False

Cause
This issue occurs because the Address Book service does not correctly handle the negative value of the Environment.TickCount property after the server has been running for 25 days or more. This causes a System.ArgumentOutOfRangeException exception to be thrown.
Resolution
To resolve this issue, install the following update rollup:
2803727 Description of Update Rollup 1 for Exchange Server 2010 Service Pack 3

Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
More information
For more information about the Environment.TickCount property, go to the following Microsoft website:For more information about the Address Book service, go to the following Microsoft website:
Properties

Article ID: 2777742 - Last Review: 05/30/2013 00:01:00 - Revision: 1.0

  • Microsoft Exchange Server 2010 Service Pack 3
  • kbqfe kbfix kbsurveynew kbexpertiseinter KB2777742
Feedback