Centralized Logging Service Agent Service cannot start after you install a September 2014 update for Lync Server 2013

Symptoms
You install September 2014 Cumulative Update 5.0.8308.815 for Microsoft Lync Server 2013. Before that, you did not install August 2014 Cumulative Update 5.0.8308.738. In this situation, the Centralized Logging Service Agent Service (RTCCLSAGT) cannot be started or cannot capture data. 

Additionally, you receive the following event in the Event Viewer.

Lync Server Centralized Logging Service Agent Service could not be started.
Source: LS Centralized Logging Agent
Event ID: 33005
Description:
Exception: Could not load file or assembly ‘Microsoft.Rtc.ClsAgent.IISLog, Version=X.X.X.X, Culture=neutral, PublicKeyToken=XXXXXXXXXXXXXXXX′ or one of its dependencies. The system cannot find the file specified. 
Exception type: FileNotFoundException
Additional Data:
Source: ClsAgent
Stack Tracer.Trace:
at Microsoft.Rtc.ClsAgent.AgentCore.InitializeAgentCore()
at Microsoft.Rtc.ClsAgent.ClsAgent..ctor(ClsAgentService service)
at Microsoft.Rtc.ClsAgent.ClsAgentService.StartAgent()
at Microsoft.Rtc.ClsAgent.ClsAgentService.OnStart(String[] args)
Data: 0 key/value pairs
Inner Exception:
Cause: Exception during startup
Resolution:
Check the events prior to this to resolve the service startup issue.

Resolution
To resolve this issue, install the following cumulative update:
3003358 October 2014 Cumulative Update 5.0.8308.831 for Lync Server 2013 core components
More information
Cause
This issue occurs because the Microsoft.Rtc.ClsAgent.IISLog folder is missing from the .Net global assembly cache after you install September 2014 Cumulative Update 5.0.8308.815 for Lync Server 2013. Therefore, the Centralized Logging Service Agent Service does not listen on designated ports. 
Properties

Article ID: 3008181 - Last Review: 03/10/2016 07:28:00 - Revision: 2.0

Microsoft Lync Server 2013

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