HIS2013 CU3\COD: HIS 2013 MQSC Adapter fails with reason code 2394 when it uses UTF-8 encoding

Summary
Consider the following scenario:
  • You upgrade to Microsoft Host Integration Server 2013 Cumulative Update 3 and then set the Microsoft BizTalk Adapter for WebSphere MQ (MQSC Adapter) to use UTF-8 encoding.
  • You run the MQSC Adapter server. 

In this scenario, the MQSC Adapter server throws the following warning:

Biztalk Server, Event ID 5740

The Adapter "MQSC" raised an error message.
Details "Failure encountered while attempting to get message from queue. queue = <Queuename>, queueManager = <QueueManagerName>, reason code = 2394".
Cause
The MQSC Adapter doesn't handle UTF-8 encoding after the update to Cumulative Update 3.
Resolution
After you apply the hotfix that's mentioned in this section, the MQSC Adapter correctly handles UTF-8 encoding.

Hotfix/Update information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem that is described in this article. This hotfix might receive additional testing. Therefore, if you're not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix. 

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to get the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that don't qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: 

Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you don't see your language, this is because a hotfix isn't available for that language. 

Prerequisites


You must have cumulative update package 3 for Microsoft Host Integration Server 2013 installed to apply this hotfix. For more information about how to get the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
3019572 Cumulative update package 3 for Host Integration Server 2013

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Vlastnosti

ID článku: 3108144 - Poslední kontrola: 12/03/2015 21:39:00 - Revize: 1.0

Microsoft Host Integration Server 2013

  • kbqfe kbsurveynew KB3108144
Váš názor