FIX: MQSeries adapter stops processing messages in BizTalk Server

Symptoms
You use the MQSeries adapter in Microsoft BizTalk Server to send messages to and receive messages from an MQSeries server. However, you discover that several transactions have been rolled back, and that the MQSeries adapter stops processing messages if the target MQSeries queue is full.
Cause
This issue occurs because the MQSeries adapter doesn't correctly handle the "queue full" error in all situations.
Resolution

Cumulative update information

This issue was first fixed in the following cumulative update of BizTalk Server:
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
References
For information about the service packs and cumulative update list for BizTalk Server, see KB 2555976: Service pack and cumulative update list for BizTalk Server.

For more information about BizTalk Server hotfixes, see KB 2003907: Information about BizTalk hotfixes and cumulative update support.
Properties

Article ID: 3133138 - Last Review: 04/13/2016 20:39:00 - Revision: 2.0

Microsoft BizTalk Server Branch 2010, Microsoft BizTalk Server Developer 2010, Microsoft BizTalk Server Enterprise 2010, Microsoft BizTalk Server Standard 2010, Microsoft BizTalk Server 2013 Branch, Microsoft BizTalk Server 2013 Developer, Microsoft BizTalk Server 2013 Enterprise, Microsoft BizTalk Server 2013 Standard

  • kbqfe kbsurveynew kbfix kbexpertiseadvanced KB3133138
Feedback